X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

What is wrong with firefox?

Posted

What is wrong with firefox?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • VLC media player Web Plugin 2.0.2
  • Plug-in for detecting Nero Kwik Media.
  • 5.1.10411.0
  • Zeon PDF Plugin For Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96854 answers

Do you have any problems with Firefox?