X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

IDM Add-on, not supported by Firefox v. 15.... When and how will it be back?

Posted

I rely on this application for direct downloads and need it. I could revert to Firefox 14 but it would mean I would have security issues unresolved. How does one get the product in question to update the Add-on? I cannot get into their website either.....

Chosen solution

hello, here seems to be the latest version of the addon available that should also work with firefox 15: http://www.internetdownloadmanager.com/support/firefox_integration.html

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8897 answers

Chosen Solution

hello, here seems to be the latest version of the addon available that should also work with firefox 15: http://www.internetdownloadmanager.com/support/firefox_integration.html

Helpful Reply

There must be some reason for me not to have access to that page, at least from Firefox. I wonder if I can do this with Google Chrome?? I'll try and let you know.

Helpful Reply

I still can't access the page, but have managed to enter the page's caché where the same question arises. It is due to my not having the latest version of Firefox_integration.... Or so it seems. Thanks so much for your help. I will have to reinstall, although the add-on I have is 7. x x x x which should work. I'll have a go at reinstalling. THANKS AGAIN!