X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Already uninstalled and removed funmoods but it keeps appearing

Posted

when i go to about:home and do a search i get sent to funmoods search instead of google or avg search like before, even though i have already removed the extension, when i take a look at about:config the extension still appears so i go to addons, extensions to take a look but is not there so i cant re-remove it, i had thought the problem had been fixed but with firefoxs newest update the problem came back, what could i do?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Update
  • npsitesafety
  • Pando Web Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • Facebook Video Calling Plugin
  • NPWLPG
  • VLC media player Web Plugin 2.0.0-rc
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

See:

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.


If you do not keep changes after a restart then see:

Question owner

Well it stopped redirecting me to funmoods but now i cant search anything, any last ideas

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Did you try to delete the chromeappsstore.sqlite file and repeated the step to reset the browser.startup.homepage_override.mstone pref to make sure that the search engine on the about:home get initialized correctly?

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

Or you can simply Reset Firefox, which will resolve this in just one click.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Note that a "Reset" creates a new profile and tries to import some settings from the old profile leaving the old profile intact, including the cache folder (about:cache) that can take up to 1 GB.

Firefox 15+ versions will move the old profile folder to an "Old Firefox Data-##" folder on the Desktop that gets a number appended if you use reset more than once, so you can no longer use the profile manager to revert to the old profile.

It is best to first try some basic steps to repair your current profile folder instead of creating a new profile via a reset.

Question owner

Yeah, I deleted chromeappsstore.sqlite file, and repeated the step for browser.startup.homepage_override.mstone, i tried resetting a couple of times but its not working and if i would lose my bookmarks and the like id rather not reset the browser, I still cant search from about:home

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

A Firefox Reset won't cause you to lose your bookmarks, so if you haven't tried it yet I'd strongly recommend it.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

You can inspect the current search engine via this code in the Web Console panel with the about:home page on display.

  1. open the about:home page in a tab
  2. open the Web Console via Ctrl+Shift+K or Firefox > Web Developer > Web Console
  3. paste the code in the Web Console command line that gets selected when you open that panel (Ctrl+V).
localStorage["search-engine"]

Copy the result via the right-click context menu to the clipboard and paste it here.

Question owner

[17:00:19.939] SyntaxError: JSON.parse: unexpected character @ chrome://browser/content/abouthome/aboutHome.js:145

[17:00:19.945] Exposing chrome JS objects to content without __exposedProps__ is insecure and deprecated. See https://developer.mozilla.org/en/XPConnect_wrappers for more information. @ http://toolbar.avg.com/si.js?p=HxBY1LyQFAZIbE%2fKDlzYvmDdPBDY0R0vmECVHq7qf5i1rLpJX3KJEFQErWU18SmTKpQeon6mYUarLJTI8omXKHzmhai6H4xjlTD%2f5ZiF4Q9aV68YbjyrxZ0y%2fw5rcyistSh4IS5cJfYWsFF1CTJ1gd539G9h%2B6GlEPWmvUmpAyYZvpAcDQumdIv%2Ba57BAyRrTPxlfM9kA2NLDeH5yiWMzrMje0ISOYw8NK3Dij8HmN24aB1QNsp2KR06AA%3D%3D:7

Like that?

Modified by Cyead