X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't open files with MS Word by default

Posted

I want to download .doc and .docx files from my email. When I click to download, Firefox asks me which program I want to open it with. MS Word is not on the list so I go to Browse>Office14>WINWORD.exe

At this point Firefox recognises Word and opens the file correctly. However, the next time I want to download a file the exact same thing happens, even though I ticked "do this automatically for files like this" AND have changed the default program to MS Word (in Options>Applications) for both kinds of files.

I have already tried completely uninstalling then reinstalling both Firefox (15.0) and Microsoft Office (2010) including wiping my FF settings.

FF follows all the other default program settings, it's only with Word that it does this.

(btw I am running Windows 7)

I want to download .doc and .docx files from my email. When I click to download, Firefox asks me which program I want to open it with. MS Word is not on the list so I go to Browse>Office14>WINWORD.exe At this point Firefox recognises Word and opens the file correctly. However, the next time I want to download a file the exact same thing happens, even though I ticked "do this automatically for files like this" AND have changed the default program to MS Word (in Options>Applications) for both kinds of files. I have already tried completely uninstalling then reinstalling both Firefox (15.0) and Microsoft Office (2010) including wiping my FF settings. FF follows all the other default program settings, it's only with Word that it does this. (btw I am running Windows 7)

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • npsitesafety
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

jscher2000
  • Top 10 Contributor
3258 solutions 29716 answers

Can you download and launch Word files normally from other sites, such as: http://download.microsoft.com/downloa.../internetexplorer8.doc

If so, it could be an issue on the mail provider's server. If the mail server is sending a generic content type ("application/octet-stream"), then Firefox won't actually associate that with any particular application (I suspect because it also is used for executable files).

Sometimes the Open/Save/Cancel dialog will show you the "content type" indicated by the server. Is that information available?

Is this a mail provider that would accept some constructive input on this issue?

Can you download and launch Word files normally from other sites, such as: [http://download.microsoft.com/download/b/d/5/bd515214-0728-4a54-9625-ab3f198cf448/internetexplorer8.doc] If so, it could be an issue on the mail provider's server. If the mail server is sending a generic content type ("application/octet-stream"), then Firefox won't actually associate that with any particular application (I suspect because it also is used for executable files). Sometimes the Open/Save/Cancel dialog will show you the "content type" indicated by the server. Is that information available? Is this a mail provider that would accept some constructive input on this issue?

Modified by jscher2000

Question owner

I have two accounts, one BT Yahoo mail and the other normal Yahoo mail, I have the same problem in both.

When the open/save box comes up it says "you have chosen to open [filename] which is a doc file".

I have done some further testing and bizarrely:

-the file you linked comes up in Word just fine

-the .doc attachments open automatically in Word from other computers using FF or on this one if I use Internet Explorer.

So the problem is only when I'm specifically using FF on this particular computer to open email attachments.

I have two accounts, one BT Yahoo mail and the other normal Yahoo mail, I have the same problem in both. When the open/save box comes up it says "you have chosen to open [filename] which is a doc file". I have done some further testing and bizarrely: -the file you linked comes up in Word just fine -the .doc attachments open automatically in Word from other computers using FF or on this one if I use Internet Explorer. So the problem is only when I'm specifically using FF on this particular computer to open email attachments.
jscher2000
  • Top 10 Contributor
3258 solutions 29716 answers

Are there any differences in your Firefox add-ons (esp. any download-related extensions) or external security/proxy software between the two PCs (i.e., the one where Firefox works normally and the one where it doesn't)?

Are there any differences in your Firefox add-ons (esp. any download-related extensions) or external security/proxy software between the two PCs (i.e., the one where Firefox works normally and the one where it doesn't)?
jscher2000
  • Top 10 Contributor
3258 solutions 29716 answers

Actually, you might as well try resetting your application options first before doing all that comparing in case it's just a glitch. This involves renaming a file in your personal settings (AKA Firefox profile) folder. The steps are in this article: https://support.mozilla.org/en-US/kb/cant-download-or-save-files#w_reset-...

Actually, you might as well try resetting your application options first before doing all that comparing in case it's just a glitch. This involves renaming a file in your personal settings (AKA Firefox profile) folder. The steps are in this article: [https://support.mozilla.org/en-US/kb/cant-download-or-save-files#w_reset-download-actions-for-all-file-types]

Question owner

Okay I've tried that and it doesn't solve the problem - I didn't think it would since I'd already reinstalled FF from scratch with default settings.

I think the problem must lie with MS Office, since I've noticed a couple of other problems while trying to fix this - some of the file icons are strange and no MS Office programs appear on the "Set Default Programs" list. (Weirdly though, FF will happily open Excel attachments)

Thanks anyway for your help! I will try to find out what the problem is with Office and that might fix it.

Okay I've tried that and it doesn't solve the problem - I didn't think it would since I'd already reinstalled FF from scratch with default settings. I think the problem must lie with MS Office, since I've noticed a couple of other problems while trying to fix this - some of the file icons are strange and no MS Office programs appear on the "Set Default Programs" list. (Weirdly though, FF will happily open Excel attachments) Thanks anyway for your help! I will try to find out what the problem is with Office and that might fix it.