X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why did FireFox update without permission, I had it set to check, but let me decide if I want to install? Now I've set it to never check. What gives?

Posted

Why did FireFox update without permission, I had it set to check, but let me decide if I want to install? Now I've set it to never check. What gives?

Additional System Details

This happened

Just once or twice

This started when...

tonight

Installed Plug-ins

  • Amazon MP3 Downloader Plugin 1.0.17
  • Shockwave Flash 11.2 r202
  • 4.1.10329.0
  • VLC media player Web Plugin 2.0.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

finitarry 157 solutions 2175 answers

I prevented Firefox from updating altogether. I never want it to auto-update. These are the settings I have in about:config:

  • app.update.auto - false
  • app.update.enabled - false
  • app.update.silent - false

Oh, by the way, do not trust that "Check for updates" button in the about:Firefox window. That should have been renamed to "Get updates".

Modified by finitarry

Helpful Reply

All I wanted, was it to notify me & let me decide. Yeah I've turned off the update completely. I just dislike heavy-handed tactics. Yeah I discovered it was a get update button a while back. :~P I went to FF because I hated IE & also I don't trust Chrome. I want a browser that functions the way I tell it. Why is that too much to have?

Oh well... Thanks for replying.

ikaruseijin 0 solutions 8 answers

I did the same thing, clicked on "check for updates..." now I have a new version "waiting to be applied" despite the fact I never gave permission for the update to be downloaded.

I am not happy with this, and given I have already stopped using Firefox most of the time, I may well uninstall it entirely after this.

finitarry 157 solutions 2175 answers

Firefox still works well. Just never trust that "Check for Updates" button again. The first time Firefox pulled that trick, I force quitted it, and deleted the partially downloaded update file. The same thing goes for Thunderbird.

Garythemessage 0 solutions 1 answers

I just turned on my netbook (W7 32 bit) and it took nearly a dozen tries to get Firefox to launch. When it finally did launch, it was wonky and many of the "about:config" changes I had made were changed back to default. My home pages was also reverted back to Firefox's default search page. I eventually discovered that Firefox had updated to version 19.0.

I always keep all my PCs with auto-update disabled. I've been a PC dude for 20+ years - professionally. I know for a fact that I had updates turned off in Firefox's options. It updated anyway. I did not click any buttons that said "check updates." I remember exactly what I had done on my netbook previously and am 100% certain I had nothing to do with the update. My netbook is free from viruses and is functioning as normally as ever - except for Firefox breaking the rules.

I don't want to know how to keep Firefox from updating. I want to know why it updated regardless of my wishes and choices. Now I have to go back and turn of Flash and animated images and all that, all over again. Pain in the butt. Regardless of all that: updating should not have toggled my configs back to default!

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Helpful Reply

when your preferences didn't save then it might be also true that your update specific settings didn't stick & that's why your instance auto-updated. some security software might interfere here (also when launching firefox isn't working normally). also see How to fix preferences that won't save