X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I try to go to washpost.com (my homepage), I am redirected to m.washpost.com (mobile site) - site begins to load, then redirects over and over again.

Posted

This is new issue as this morning t was running fine then I refreshed home page and browser got into a loop of attempts to keep loading (desktop version of page) and then redirecting back to mobile version. Over and over. I clear cache and cookies and the Loop stops (temporarily) but the redirects to the mobile page seems to now be the default response to the www.washingtonpost.com site for this browser. Works fine in safari and chrome. So...i upgraded to ff14 (whihc I had been waitng on and same deal thing still occurs.

Additional System Details

This happened

Every time Firefox opened

This started when...

today out of the blue

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Version 3.4.2.8800
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • AmazonMP3DownloaderPlugin 1.0.15
  • 4.0.60831.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

I have tried safe mode start up and upgraded FF but no luck. reading somewhere the about:config (entered in browser bar) might have some clue and I can get theere but not certain what (or how) to prporly edit.

Marc Sances 22 solutions 242 answers

Your user agent may have changed.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

If you don't mind digging under the covers, you could try changing your useragent directly. See Websites say that Firefox is outdated or incompatible even though it's the latest version.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Do you have your cookie management set to "ask me every time"? A new cookie-related issue has emerged for some websites that causes inexplicable behavior. Please see these threads for examples and a workaround:

Question owner

I tried changing user agent directly but no solution there. Moving on the default procedure but not excited about reinstalling extension and addons. oh well.

Marc Sances 22 solutions 242 answers

Does it work on IETab?

Question owner

I assume you meant IE user agent. Tried it but still no go.

Marc Sances 22 solutions 242 answers

No, I meant IETab extension. https://addons.mozilla.org/en-US/firefox/addon/ie-tab/

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

Helpful Reply

marcsances, please check on which platform the OP is before doing suggestions about using IE. On a Mac that doesn't apply and thus isn't possible.

See also:

Marc Sances 22 solutions 242 answers

Ok, ok, don't get angry, please... Maybe the source of the problem is not the user agent, maybe just it detects he/she has Mac OS and thinks he/she has an iOS device. Just tell us: how do you perform redirect to mobile version? Do you detect user agent, or you use another method?