Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has the critical problem with foreign languages e.g. Russian in Address bar! How to fix this?

  • 14 replies
  • 1 has this problem
  • 356 views
  • Last reply by cor-el

more options

When I put address into Address bar in Russian I see Google instead of my site. I don't want Google. Help please.

Chosen solution

When there is a space in the URL, the address bar search may kick in.

Not sure whether the preference you changed is used anywhere else. Another way to disable address bar search is:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste keyword and pause while the list is filtered

(3) Double-click keyword.enabled to toggle it from true to false.

Read this answer in context 👍 0

All Replies (14)

more options

Please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. You really help us to visualize the problem.

more options

Sorry.This problem is not only with Russian. It's a global problem with Address bar. I cannot put any address into Address bar.

more options

Why do you want screenshot? Havn't you seen Google? I tried to put address into Address bar in English. But received abracadabra.

I put "http://localhost/MInfo/app.php" Firefox changes it to "http://localhost/MInfo/app.localhost/MInfo/app.php"

more options

If you've noticed this problem only since installing Firefox 14, could you try disabling the URL autofill feature?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste autofill and pause while the list is filtered

(3) Double-click browser.urlbar.autoFill to toggle it from true to false.

more options

It helped with second problem. Now I can put url in English. But Google remains to be intrusive when I put it in Russian.

more options

I see what you mean. That is definitely autocompletion or Hosts issue. jscher2000 has telled you well. But maybe it would be that your hosts file doesn't redirect you to your loopback IP. Please replace "localhost" with "127.0.0.1" and try again.

more options

I have found it. about:config browser.search.defaultenginename = nothing Thanks

Modified by axdr

more options

Oh... crossed replies...

Ok I correct my reply. That is because Firefox detects non-standard characters on the URL. Until IDN started to work, all characters had to be in English.Maybe you can try to replace each russian character with a Unicode or Latin-1 equivalent character, such as %3C or similar.

more options

Well... that is intrusing your search engine!

more options

Chosen Solution

When there is a space in the URL, the address bar search may kick in.

Not sure whether the preference you changed is used anywhere else. Another way to disable address bar search is:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste keyword and pause while the list is filtered

(3) Double-click keyword.enabled to toggle it from true to false.

more options

Yes. It also works "http://localhost/wCatalogs/%D0%9B%D0%B5%D1%87%D0%B5%D0%B1%D0%BD%D1%8B%D0%B5%20%D1%80%D0%B0%D1%81%D1%82%D0%B5%D0%BD%D0%B8%D1%8F/converter/y_dis_types.php?write=1" But Firefox changes it to Cyrillic :( And we are back to square A.

Modified by axdr

more options

Thanks a lot

more options

Is your encoding on the source code correctly set to UTF-8???

more options

IDN only applies to the (top) domain and with a localhost link it shouldn't matter.

It also shouldn't have effect whether you use Cyrillic or encodeURIComponent() for path names.
Space in path names do matter and should be encoded as %20 or best avoided and replaced with a hyphen or underscore.

Modified by cor-el