X
Tap here to go to the mobile version of the site.

Support Forum

Firefox can not connect to proxy server

Posted

I use a proxy server. When I manually configure the proxy settings it does not work and give the error message as "can not connect to proxy server." But instead when I keep proxy setting as 'use system proxy settings' then it works fine But it causes other problems. I want that it work with manual proxy settings. P.S.: Using no proxy is not a solution for me. Please do not suggest me the same.

I use a proxy server. When I manually configure the proxy settings it does not work and give the error message as "can not connect to proxy server." But instead when I keep proxy setting as 'use system proxy settings' then it works fine But it causes other problems. I want that it work with manual proxy settings. P.S.: Using no proxy is not a solution for me. Please do not suggest me the same.

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated Firefox

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Version 3.4.2.8800
  • Google Update
  • Shockwave Flash 11.3 r300
  • 4.1.10329.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

dumdidadida 155 solutions 1440 answers

Hi,

Please try updating Firefox to the latest. You can then Reset Firefox via Help (Alt + H) > Troubleshooting Information. If the problem persists, please also try to Import data from another browser via Firefox Bookmarks (Alt + B) > Show All Bookmarks > Import and Export. Choose Internet Explorer, and Internet Options in the next screen.

(To revert to the previous profile you were using, close the new profile (i.e. exit Firefox), start Firefox and choose the Default User profile. While the Profile Manager is open, you can also delete the newly reset profile (the one containing random numbers), or the former profile, as the case may be). If the reset is okay, it would be a good idea to delete the old profile as otherwise it would be left intact with the previous data/cache until deleted.

Managing profiles

Profiles Howto

Hi, Please try [https://www.mozilla.org/en-US/firefox/new/ updating Firefox] to the latest. You can then [https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems Reset Firefox] via '''Help''' ('''Alt''' + '''H''') > '''Troubleshooting Information'''. If the problem persists, please also try to '''Import data from another browser''' via Firefox '''Bookmarks''' ('''Alt''' + '''B''') > '''Show All Bookmarks''' > '''Import and Export'''. Choose Internet Explorer, and '''Internet Options''' in the next screen. (To revert to the previous profile you were using, close the new profile (i.e. exit Firefox), start Firefox and choose the '''Default User''' profile. While the [https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Profile Manager] is open, you can also delete the newly reset profile (the one containing random numbers), or the former profile, as the case may be). If the reset is okay, it would be a good idea to delete the old profile as otherwise it would be left intact with the previous data/cache until deleted. [https://support.mozilla.org/en-US/kb/Managing-profiles Managing profiles] [https://support.mozilla.org/en-US/kb/Profiles?s=profile&r=2&e=sph&as=s Profiles Howto]

Modified by dumdidadida

Question owner

Thanks for the reply..... But it did not work........ The problem is as it was........

Thanks for the reply..... But it did not work........ The problem is as it was........
dumdidadida 155 solutions 1440 answers

Import data from another browser usually is the same as using system settings. Can you please create a screenshot of the error page you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. You really help us to visualize the problem.

Import data from another browser usually is the same as using system settings. Can you please create a screenshot of the error page you're seeing by following the guide mentioned at [[How do I create a screenshot of my problem?]]. Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. You really help us to visualize the problem.

Helpful Reply

Here is the error report I am getting. I am also attaching the proxy settings which I am using. The same proxy settings I used before also and they were working fine. But since last 20 days it is creating problem.

Here is the error report I am getting. I am also attaching the proxy settings which I am using. The same proxy settings I used before also and they were working fine. But since last 20 days it is creating problem.
dumdidadida 155 solutions 1440 answers

You can try to set network.proxy.socks_remote_dns to true in about:config. Otherwise you can also try to just enable the SOCKS Host while leaving the rest including the Use this proxy server for all protocols blank/unchecked.

about:config Entries

You can try to set '''network.proxy.socks_remote_dns''' to '''true''' in [http://kb.mozillazine.org/About:config about:config]. Otherwise you can also try to just enable the SOCKS Host while leaving the rest including the '''Use this proxy server for all protocols''' blank/unchecked. [http://kb.mozillazine.org/About:config_entries about:config Entries]

Question owner

Sorry, But still not solved. I am thankful to your continuous effort to look after my problem.

Sorry, But still not solved. I am thankful to your continuous effort to look after my problem.
dumdidadida 155 solutions 1440 answers

Well actually that was, you have to set the SOCKS Host, and also network.proxy.socks_remote_dns to true. Sorry about that. If it's still not working a good start would be to check with the network admin regarding the type of proxy. You can also try to copy the Internet Explorer settings from Internet Options > Connections > Lan Settings.

Well actually that was, you have to set the '''SOCKS Host''', and also '''network.proxy.socks_remote_dns''' to true. Sorry about that. If it's still not working a good start would be to check with the network admin regarding the type of proxy. You can also try to copy the Internet Explorer settings from '''Internet Options''' > '''Connections''' > '''Lan Settings'''.

Helpful Reply

Actually I verified that with the same settings my friends are comfortably using it. They are not facing any problems. That means it is not a problem from administrator's side. Even I used the same settings. I did not face the problem earlier. I also formatted my computer and reinstalled everything. I tried all the ways you suggested but still not getting fixed. I think I have the only option to use another browser.

Actually I verified that with the same settings my friends are comfortably using it. They are not facing any problems. That means it is not a problem from administrator's side. Even I used the same settings. I did not face the problem earlier. I also formatted my computer and reinstalled everything. I tried all the ways you suggested but still not getting fixed. I think I have the only option to use another browser.