X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want firefox in ENGLISH NOTHING ELSE

Posted

I want to browse the internet in english, I want my firefox to be in english and I dont want to have to set google back to english everytime I'm trying to search something. I dont know why Mozilla thinks everything has to be translated now a days, but some people like me can actually read and write english despite not living in an english speaking country. I do all my work from my computer, which involves a lot of research and general doing stuff on the internet, and troubleshooting something or looking something up has always been and will always be easier and more comprehensive in english. WHAT should I do? PLEASE.

Additional System Details

This happened

Every time Firefox opened

This started when...

Some genious at Mozilla decided that noone knows english unless they live in UK or USA.

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.3 r300
  • Pando Web Plugin
  • 1.122.0
  • 4.1.10329.0
  • 1.118.0
  • Winamp Application Detector
  • 0.70.4
  • QUAKE LIVE
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • npbyond

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Look, even this is not in english! And what if I'd ONLY know english and just moved to another country? The menus and everything would AUTOMATICALLY be in a language I dont understand.
Programfakta
Namn
Firefox
Version
14.0.1
Användaragent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profilmapp
Öppna mapp
Aktiva insticksmoduler
about:plugins
Byggkonfiguration
about:buildconfig
Kraschrapporter
about:crashes
Minnesanvändning
about:memory
Tillägg
Namn
Version
Aktiverad
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
BrowserProtect
1.1.3
true
browserprotect@browserprotect.com
EPUBReader
1.4.2.1
true
{5384767E-00D9-40E9-B72F-9CC39D655D6F}
Fasterfox Lite
3.9.7Lite
true
FasterFox_Lite@BigRedBrent
FireFTP
2.0.5
true
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
Google Docs Viewer
1.8
true
adonis.cuhk@gmail.com
img2tab
1.67
true
sumeetkpatel@gmail.com
Java Console
6.0.33
true
{CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
Save Images
0.7.9
true
LDSI_plashcor@gmail.com
Speed Dial
0.9.6.8
true
{64161300-e22b-11db-8314-0800200c9a66}
Viktiga ändrade inställningar
Namn
Värde
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
76800
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
727040
browser.places.smartBookmarksVersion
4
browser.startup.homepage
chrome://speeddial/content/speeddial.xul
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
browser.tabs.closeWindowWithLastTab
false
browser.tabs.warnOnClose
false
dom.max_chrome_script_run_time
0
dom.max_script_run_time
0
extensions.lastAppVersion
14.0.1
font.name.monospace.x-western
Trebuchet MS
font.name.sans-serif.x-western
Trebuchet MS
font.name.serif.x-western
Trebuchet MS
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
network.dnsCacheEntries
512
network.dnsCacheExpiration
3600
network.http.max-connections
48
network.http.max-connections-per-server
24
network.http.max-persistent-connections-per-proxy
16
network.http.max-persistent-connections-per-server
8
network.http.pipelining
true
network.http.pipelining.maxrequests
8
network.http.pipelining.ssl
true
network.http.proxy.pipelining
true
network.prefetch-next
false
places.database.lastMaintenance
1343507237
places.history.expiration.transient_current_max_pages
104858
privacy.cpd.offlineApps
true
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Grafik
Adapterbeskrivning
AMD Radeon HD 6900 Series
Leverantörs-ID
0x1002
Enhets-ID
0x6718
Adapter-RAM
2048
Adapterdrivrutin
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Drivrutinsversion
8.970.0.0
Drivrutinsdatum
4-18-2012
Direct2D aktiverat
true
DirectWrite aktiverat
true (6.1.7601.17514)
ClearType-parametrar
Hittade inga ClearType-parametrar
WebGL-renderare
Google Inc. -- ANGLE (AMD Radeon HD 6900 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
Grafikaccelererade fönster
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Biblioteksversioner
Förväntad minimiversion
Version som används
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

It is probably Google doing this. You can click the link to go to Google.com. Such a setting is stored in a cookie on your computer, so if you do not keep that cookie via an allow exception or remove it otherwise then Google will revert to the local page you need to redo the change to the English site.

James
  • Top 25 Contributor
  • Moderator
437 solutions 3148 answers

I agree that it is Google going based on your IP location.

JoseLuis999 0 solutions 2 answers

I cannot understand what you wrote. I still have no idea what to do. I function only in ENGLISH but I live in Argentina. Firefox thinks I out to always go to Google.ar, but that is deleted by a moderator. I want Google.com in USA ONLY. Please help directly to email address deleted. Thank you

Edited by a moderator due to language. See the Rules & Guidelines .

Modified by the-edmeister

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

The localized Google pages have a link at the bottom to got to the international (English) Google.com page.

Such a choice is kept in a Google PREF cookie, so you need to make sure to keep that cookie and if necessary create an allow exception.

  • Tools > Options > Privacy > Cookies: "Exceptions"
JoseLuis999 0 solutions 2 answers

There is no provision of such a list as "Tools > Options > Privacy > Cookies: "Exceptions"" beyond Tools.....

Let me also say here in a general way that Mozilla Firefox really irritates me, unlike Internet Explorer. IE ALWAYS comes up in ENGLISH. And IE provides an easy way to dump/erase a website address when I want to weed the search table. Why can't Firefox be as considerate? I have to believe that most of the users are not computer nerds who can sort out a problem but many are like me, very old and unschooled in computer software mysteries.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

If you are not on Windows then instead of Tools > Options use:

  • Mac: Firefox > Preferences
  • Linux: Edit > Preferences
  • Windows: Firefox > Options

Press F10 if the menu bar is hidden on Windows and Linux or use "Firefox > Options/Preferences"


To see all history and cookie settings, use:

  • Tools > Options > Privacy > History: Firefox will: "Use custom settings for history"