X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Yahoo stole my newtab page and I want it back!

Posted

OK. I really liked the new-tab page Firefox came up with, then my brother downloaded Yahoo crap and I uninstalled it. The problem I have is that whenever I open a new tab, it still opens a yahoo search page. I looked everywhere online for information to get my new-tab page back, but all I found was how to get rid of it.

I'm not a computer person, so when they say 'open Firefox and type ___________.' I have no idea what they are talking about. To top it off, there is no little box in the upper right corner to click like all the help sites say. It's just a regular yahoo search page, and it's driving me nuts. I've looked about the web all day off and on for this. At this point, I'd be happy with figuring out how to get a blank page, but I don't know how to get to where I'm suppose to type 'about:blank' to do it.

I tried uninstalling Firefox and then installing it again too, thinking that it might reset things. It didn't. I still see yahoo. I hope you can help. I really miss my new-tab page.

Chosen solution

See this article about the New Tab (about:newtab) page:

You can check the browser.newtab.url pref on the about:config page and if it is user set (bold) then reset the pref to the default via the right-click context menu.


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Google Update
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 4.1.10329.0
  • PopCap Games Plugin
  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Application Basics
Name
Firefox
Version
14.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Freeze.com NetAssistant
3.6.5
true
{1266764D-FC4F-4FA7-B63B-884D53B1680F}
Pray Times!
1.1.7
true
azan-times@hamid.net
Norton Toolbar
2012.7.4.1
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Norton Vulnerability Protection
11.0.0.243 - 2
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
RealPlayer Browser Record Plugin
15.0.5
false
{C3949AC2-4B17-43ee-B4F1-D26B9D42404D}
Skype Click to Call
6.1.0.10441
false
{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.loseit.com/?welcome=1
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
extensions.lastAppVersion
14.0.1
font.internaluseonly.changed
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1343555044
places.history.expiration.transient_current_max_pages
102076
places.history.expiration.transient_optimal_database_size
163320298
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.history
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed.show_once
false
Graphics
Adapter Description
Intel(R) HD Graphics
Vendor ID
0x8086
Device ID
0x0046
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2372
Driver Date
4-15-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

See this article about the New Tab (about:newtab) page:

You can check the browser.newtab.url pref on the about:config page and if it is user set (bold) then reset the pref to the default via the right-click context menu.


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Question owner

Thank you Cor-el! I was confused with your advice at first, but then I finally figured out how to get to the about:config page and everything started to make sense. I sort of felt like a computer person for a minute. hehe. Anyways, the 'browser.newtab.url' was not bold and I couldn't reset it. So, I checked your other links and found out how to run Firefox in 'safe mode' and then figured out that the I had a new-tab page in 'safe mode', which meant that it was an extension problem.

I went to the add-on list and removed 'net-assistant' because it was the only thing I didn't recognize. I got my new-tab page back!! Yay!! I didn't know 'yahoo' was disguised as 'net assistant', or I would have deleted it first thing. Thank you so much for leading me to not only fixing this problem, but allowing me to discover more about my computer in the process. You Rock!

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

Helpful Reply

Your search settings may have also been changed. You might want to use this add-on to set them all back to default - https://addons.mozilla.org/firefox/addon/searchreset/