Question

Tried to install Firefox 14.0.1. Won't install, says I need XP, but I have XP.

Downloaded Firefox 14.0.1. Would not install. Got message: "This version of Firefox requires Microsoft Windows XP SP2 or newer."

I have dial-up and it took an hour to load, now it won't install. Very frustrating, particularly as I have Windows XP. Why won't it load?

Thank you.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post
  • owner
  • post
  • owner
  • solution
  • owner
  • post
  • post
  • post