X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does 'Get Add-Ons' hang on 'Loading'?

Posted

'Appearance' displays a blank page.

Chosen solution

So that persona is still in the value of the lightweightThemes.usedThemes pref?

You can try to delete the addons.sqlite file and possibly the extension.sqlite file as well in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • SiteAdvisor
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • McAfee MSC FF plugin DLL
  • AmazonMP3DownloaderPlugin 1.0.15
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tried restarting FF in safe mode trying to access the 'Get Add-Ons', reinstalling the program and removing extensions not needed anymore..

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

That can happen if the server is busy or if you have a lot of extensions installed (that list is send to the server to make sure not to show extensions that you've already installed).

Question owner

I just updated another two computers and they worked fine though.

Question owner

I changed the persona from the website the other day and it didn't appear in my Appearance section of the add-ons manager.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Maybe a problem with the preferences.

Did you noticed that other preferences were changed or reset?

Question owner

Preferences are fine, fully saved.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Chosen Solution

So that persona is still in the value of the lightweightThemes.usedThemes pref?

You can try to delete the addons.sqlite file and possibly the extension.sqlite file as well in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Chris Ilias
  • Moderator
116 solutions 1065 answers

It's loading web content just like any website, so the same solutions that would be suggested if you were having this problem with a website would be used. In this case, you could try removing your addons.mozilla.org cookies.

  1. Click on the Firefox button, then select Options.
  2. In the Options window, select the Privacy panel.
  3. Click on remove individual cookies.
  4. In the cookies manager, enter addons in the search field.
  5. Remove every cookie that is still listed.

For more info about cookies, visit https://support.mozilla.org/en-US/kb/cookies-information-websites-store-on-your-computer

Question owner

I thought the preferences were the options of Firefox. After I read the article, I deleted the addons.sqlite file through my shredder, since it wouldn't allow me to delete it. You think that would stop me from proceeding. I left the extensions file alone. Nothing happened so I reinstalled 14.0.1 to replace the addons file. I'm think I'm done for at least 9 hours..

Question owner

It didn't fix the problem. I just posted my actions since it was only the addons not extensions I was having trouble with. Should I have done the extensions file too?

Question owner

addons sqlite and extensions sqlite files were both deleted and everything works fine now.