X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

installation on Android 2.2.1 Samsung Galaxy Ace 5380

Posted

Samsung Galaxy Ace 5380 Android 2.2.1 but can't install it as the Play Store says your device is not compatible. Please help!

Chosen solution

Sorry but the Samsung S5830 Galaxy Ace has a older ARMv6 type of cpu when a ARMv7 is needed. https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements

The good news is that Mozilla is looking to try and get ARMv6 Firefox releases in future.

Read this answer in context 8

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

ckr1989 0 solutions 1 answers

Helpful Reply

I have Samsung Galaxy Ace 5380 with Gingerbread 2.3.6 android and play store says Not compatible. Can anyone tell the reason please or is it a bug?

James
  • Top 25 Contributor
  • Moderator
437 solutions 3156 answers

Chosen Solution

Sorry but the Samsung S5830 Galaxy Ace has a older ARMv6 type of cpu when a ARMv7 is needed. https://wiki.mozilla.org/Mobile/Platforms/Android#System_Requirements

The good news is that Mozilla is looking to try and get ARMv6 Firefox releases in future.

kozaki 0 solutions 1 answers

Firefox 17 is announced compatible with ARMv6 Android 2.2+ devices Samsung Galawy Ace GT-S5830 (800MHz and 182MB RAM I believe) is on the "tested and verified compatible devices" but nope:

"Support for ANdroid ARMv6 phones with at least 800MHz processor and a minimum of 512MB of available RAM"

Goosh I wonder how many of the 250.000.000 ARMv6 Android devices will meet with the 800MHz and 512MB RAM requirements?