Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 3 replies
  • 17 have this problem
  • 43 views
  • Last reply by AliceWyman

more options

Firefox repeatedly crashes, even in safe mode. I can not type anything, it immediately crashes upon opening. I have tried uninstalling twice with AppCleaner, have gone through several forums and troubleshooting steps, and nothing seems to work. I have listed a few of the Crash IDs below, I actually have many more crash reports aside from these, but I was not able to type them all in. Everything else on my mac works except this. I have been having to use Google Chrome browser, which works fine, but I prefer Firefox. Please help, thank you in advance.

Chosen solution

Thank you Alice, I managed to finally resolve this after much frustration. I right clicked on the Firefox icon, then Get Info. The box for "Open in 32-bit mode" was checked. I UNchecked it, restarted Firefox and everything has been working fine.

Read this answer in context 👍 1

All Replies (3)

more options

Here are a couple of the crash reports from the crash IDs you furnished:

https://crash-stats.mozilla.com/report/index/38c77d0e-7049-4398-af71-578742120720 
Firefox 14.0.1 Crash Report [@ nsGetServiceByContractIDWithError::operator() ]
  
https://crash-stats.mozilla.com/report/index/003135b4-9eb5-479c-abe7-9bdef2120720 
Firefox 14.0.1 Crash Report [@ mozilla::browser::DirectoryProvider::GetFiles ] 

There weren't any bug reports listed but maybe someone here will see something helpful in the reports.

The only thing I can suggest is to check here for possible ideas:

http://kb.mozillazine.org/Firefox_crashes#Crash_when_starting_Firefox

more options

Chosen Solution

Thank you Alice, I managed to finally resolve this after much frustration. I right clicked on the Firefox icon, then Get Info. The box for "Open in 32-bit mode" was checked. I UNchecked it, restarted Firefox and everything has been working fine.

more options

Hey, that's great! Thanks for posting back with what fixed it.