X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't wanna firefox14 add www prefix for me

Posted

I don't wanna firefox14 add 'www' prefix for me there lots of domain just using root domain "xxx.com" but not this type of "www.xxx.com"

firefox14 try to add "www" there really anonying.

firefox 13 do not have this issue

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • CCTVplayer plugin for Firefox
  • np-mswmp
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

Helpful Reply

I've tried this

not work

Question owner

not work , still shows 'www' prefix

SafeBrowser 550 solutions 2392 answers

The more information that you supply, the more likely you will get an solution. Trying to guess what you have done already is not fruitful in finding an answer to your problem.

Please answer the following 4 questions:
Did you read the second article?
Did you try changing browser.fixup.alternate.enabled to false?
What else have you tried?
Did you exit Firefox and restart Firefox after making the change?

Depending on your Extensions installed, one of them could be affecting the results

  1. Use Firefox Safe Mode to find a problem with an Extension or Plugin:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Are you using a proxy to connect to the internet?

Question owner

Hey no proxy

but i'm using a DNS cache system Acrylic DNS proxy there you can check it http://sourceforge.net/projects/acrylic/?source=directory

which cache the dns query so I just set the system DNS ip to "127.0.0.1", I don't know if it's infect.

thanks

Question owner

1. yes i read the second article 2. yes I changed browser.fixup.alternate.enabled to false 3. I have tried to reinstall firefox 13.0.1 and the issus disappear 4. yes after changed value, I exit and restart times.

Question owner

Yes I have tried to disable all my addons restart, and it still add "www" prefix after i key in "domain.com" and press enter

Question owner

I've tried not to use Acrylic DNS proxy and the issue still there,

I ve install 14.0.1 three times , now i had to apply 13.0 to my firefox dir

Modified by simon0

netmeg 0 solutions 2 answers

I am having the problem too. I did NOT have this problem with any previous version of Firefox (and I've been on all of them since it was announced) It's forcing the www, and in some cases even ignoring the htaccess redirect to non-www. In other cases, it goes example.com - > www.example.com -> example.com. I'm not going through a proxy. I have three computers and they are all doing this. I've tried disabling all extensions. I tried the fix mentioned above (it's already set to FALSE) I've tried creating a new profile. IT KEEPS TRYING TO FORCE THE WWW. Because the site has an SSL certificate on the non-www domain, this causes errors. I simply have no way of knowing how many customers are getting the same error. Somewhere, somehow, there is some bug that is forcing the WWW.

Question owner

that's true. firefox does not give us choice. it's really disaapoint me

they should give this option back to us on firefox 15? or firefox 16? if not I would still stick on firefox 13..

Modified by simon0

Alan102 0 solutions 1 answers

An observation: if you have an address in your history which has no www. prefix, but requires one, then Firefox will only add the www. IF you use the inline completion. If you select the very same address from the drop down after entering a few characters, no www. is appended. The fact that the two methods have different results sounds like a bug to me - I'd expect drop-down clicking and inline completion to result in precisely the same URL.

tomfumb 0 solutions 2 answers

I just noticed this rather irritating issue in FF 14.0.1.

I don't think it is related to Domain Guessing because "Domain Guessing happens only if an actual request has been sent and fails".

I am trying to navigate to http://dev.mysite.com - which does exist. Firefox is changing this to http://www.dev.mysite.com - which doesn't exist.

If I first navigate to http://www.mysite.com, then change www to dev everything works fine. If I click on the suggested http://dev.mysite.com from the location bar everything works fine. The issue only occurs if I fully type the dev domain (this case makes the problem 10x more annoying) or if I hit Enter when the location bar suggests the dev domain.

My specific issue shouldn't affect my site's users, but this must be breaking sites all over the internet and the majority of those sites' users will blame the site itself. This is very sad as there will always be someone in the world who never upgrades past this version of the browser.

Modified by tomfumb

tomfumb 0 solutions 2 answers

Also happens in 15.0. I don't enjoy my ISP telling me that my domain doesn't exist because Firefox changed it.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

Try to set the Boolean pref browser.urlbar.autoFill to false on the about:config page.

See "Prevent Firefox from automatically completing URLs":