X
Tap here to go to the mobile version of the site.

Support Forum

Possibility to disable OSX Lion native full screen support?

Posted

The newly implemented support (in v14.0.1 as far as I can tell)) for native OSX Lion full screen support makes fullscreen pretty useless in a multi monitor setup. With the previous version it was possible to continue using the other monitors for other tasks.

Is it possible to disable the support in some way to actually have useful fullscreen support again, i.e. the way it worked before v14.0.1? Otherwise such an option is needed in my opinion.

The newly implemented support (in v14.0.1 as far as I can tell)) for native OSX Lion full screen support makes fullscreen pretty useless in a multi monitor setup. With the previous version it was possible to continue using the other monitors for other tasks. Is it possible to disable the support in some way to actually have useful fullscreen support again, i.e. the way it worked before v14.0.1? Otherwise such an option is needed in my opinion.

Modified by rtyrty

Additional System Details

Installed Plug-ins

  • Visar innehållet för Java-applet eller en platshållare om Java inte har installerats.
  • Med QuickTime Plugin kan du komma åt olika typer av multimedia på webbsidor. Mer information finns på webbplatsen QuickTime.
  • Shockwave Flash 11.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Programfakta
Namn
Firefox
Version
14.0.1
Användaragent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profilmapp
Visa i Finder
Aktiva insticksmoduler
about:plugins
Byggkonfiguration
about:buildconfig
Kraschrapporter
about:crashes
Minnesanvändning
about:memory
Tillägg
Namn
Version
Aktiverad
ID
Adblock Plus
2.1.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
All-in-One Gestures
0.22.1
true
{8b86149f-01fb-4842-9dd8-4d7eb02fd055}
BetterPrivacy
1.68
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Greasemonkey
0.9.20
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
nzbdStatus
1.0.15.1
true
sabnzbdstatus@dq5studios.com
Pentadactyl
1.0rc1
true
pentadactyl@dactyl.googlecode.com
Print
0.3.4
true
{f199da35-0a9a-4ce9-8f59-c68524deba93}
Reddit Enhancement Suite
4.1.2
true
jid1-xUfzOsOFlzSOXg@jetpack
Social Fixer
6.401
true
socialfixer@mattkruse.com
Socialite
1.5.1
true
socialite@chromakode
Viktiga ändrade inställningar
Namn
Värde
accessibility.typeaheadfind.autostart
false
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
829440
browser.link.open_newwindow.restriction
0
browser.places.smartBookmarksVersion
4
browser.search.useDBForOrder
true
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
browser.zoom.full
false
dom.disable_window_move_resize
true
dom.indexedDB.enabled
false
extensions.lastAppVersion
14.0.1
general.autoScroll
false
network.cookie.prefsMigrated
true
network.security.ports.banned
8118,8123,9050,9051
network.websocket.enabled
false
places.database.lastMaintenance
1342338884
places.history.expiration.transient_current_max_pages
100664
places.history.expiration.transient_optimal_database_size
161061272
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
57
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
security.warn_viewing_mixed
false
Grafik
Leverantörs-ID
0x10de
Enhets-ID
0x 863
WebGL-renderare
NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-7.18.18
Grafikaccelererade fönster
2/2 OpenGL
AzureBackend
quartz
JavaScript
Incremental GC
1
Biblioteksversioner
Förväntad minimiversion
Version som används
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
17583 solutions 159079 answers

Maybe disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"
Maybe disable hardware acceleration in Firefox. *Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

Question owner

Unfortunately that did not make any difference. Still the same native Lion fullscreen I'm afraid.

Unfortunately that did not make any difference. Still the same native Lion fullscreen I'm afraid.
jip-hop 0 solutions 3 answers

This is a major problem to me as well. First it was Safari, obviously. Next in line was Chrome with their OSx Lion Full Screen integration... lastly Firefox!

What browser with decent HTML5 performance am I to use in a multi monitor setup when I need full screen?

The way Firefox handled full screen on OSx Lion is the main reason I was using Firefox.

This is a major problem to me as well. First it was Safari, obviously. Next in line was Chrome with their OSx Lion Full Screen integration... lastly Firefox! What browser with decent HTML5 performance am I to use in a multi monitor setup when I need full screen? The way Firefox handled full screen on OSx Lion is the main reason I was using Firefox.
JMay9 0 solutions 3 answers

I too wish this could be turned off. I don't use multiple monitors, but the old method of fullscreen was much more efficient, especially since FF 13 when they made new windows mimic the currently active one (meaning I don't have to press the fullscreen button every time I open a new window).

Now, in 14, every new window I create while in fullscreen is a new Space in mission control that I have to worry about. I don't really feel like getting into all of it, but there are several small issues that this creates that, when combined, lead to a very unpleasant browsing experience.

I too wish this could be turned off. I don't use multiple monitors, but the old method of fullscreen was much more efficient, especially since FF 13 when they made new windows mimic the currently active one (meaning I don't have to press the fullscreen button every time I open a new window). Now, in 14, every new window I create while in fullscreen is a new Space in mission control that I have to worry about. I don't really feel like getting into all of it, but there are several small issues that this creates that, when combined, lead to a very unpleasant browsing experience.
AliceWyman
  • Moderator
240 solutions 2598 answers

rtyrty, you asked, Is it possible to disable the support in some way to actually have useful fullscreen support again, i.e. the way it worked before v14.0.1?

This question also came up here: https://support.mozilla.org/questions/932384

Related bug report: Bug 740148 - [10.7] Allow hiding toolbars for presentations.

rtyrty, you asked, ''Is it possible to disable the support in some way to actually have useful fullscreen support again, i.e. the way it worked before v14.0.1?'' This question also came up here: https://support.mozilla.org/questions/932384 Related bug report: [https://bugzilla.mozilla.org/show_bug.cgi?id=740148 Bug 740148] - [10.7] Allow hiding toolbars for presentations.
arp_fu 0 solutions 3 answers

Helpful Reply

I've built a simple addon that does just that: reverts the old pre-14 Fullscreen behavior. It isn't yet reviewed, so wouldn't show in searches until approved.

Here's the direct link: https://addons.mozilla.org/en-us/firefox/addon/old-lion-fullscreen/. Bugreports are welcome!

I've built a simple addon that does just that: reverts the old pre-14 Fullscreen behavior. It isn't yet reviewed, so wouldn't show in searches until approved. Here's the direct link: https://addons.mozilla.org/en-us/firefox/addon/old-lion-fullscreen/. Bugreports are welcome!
JMay9 0 solutions 3 answers

Thank you so much arp. Your add-on works perfectly. I left you a 5 star review. If I see any bugs I will be sure to let you know.

Thank you so much arp. Your add-on works perfectly. I left you a 5 star review. If I see any bugs I will be sure to let you know.
jip-hop 0 solutions 3 answers

Arp, thanks a million for taking time to fix this problem! Firefox, Safari and Chrome are useless for my portfolio website I designed to present my work. It's a website that uses two screens simultaneously. I immediately installed your add-on as soon as I read your reply. There is just one small bug when I use it in Mountain Lion (not sure why it happens). I have two Firefox windows open, one on each monitor. On both of them I set them to full screen, using your add-on. The main monitor works flawlessly, the second goes to full screen but leaves a blank space on top. See the attached image for an example (I hover the white space in the picture, that's why the tab bar appears). I just made a clean Mountain Lion install yesterday and your add-on is the first I installed on Firefox so I can't think of anything interfering. My second monitor is actually an Android phone acting as a wifi connected monitor (using the app iDisplay) but it was working fine for me before all this full screen api non-sense. So the white bar shouldn't be cause by that according to me.

Arp, thanks a million for taking time to fix this problem! Firefox, Safari and Chrome are useless for my portfolio website I designed to present my work. It's a website that uses two screens simultaneously. I immediately installed your add-on as soon as I read your reply. There is just one small bug when I use it in Mountain Lion (not sure why it happens). I have two Firefox windows open, one on each monitor. On both of them I set them to full screen, using your add-on. The main monitor works flawlessly, the second goes to full screen but leaves a blank space on top. See the attached image for an example (I hover the white space in the picture, that's why the tab bar appears). I just made a clean Mountain Lion install yesterday and your add-on is the first I installed on Firefox so I can't think of anything interfering. My second monitor is actually an Android phone acting as a wifi connected monitor (using the app iDisplay) but it was working fine for me before all this full screen api non-sense. So the white bar shouldn't be cause by that according to me.
arp_fu 0 solutions 3 answers

jip-hop, thanks for checking the extension! I suppose you see something that looks like this old issue: https://bugzilla.mozilla.org/show_bug.cgi?id=551235. I'll check this once I get to my second monitor, but my immediate thought is that the problem is related to how Firefox itself behaves on Mac OS X.

jip-hop, thanks for checking the extension! I suppose you see something that looks like this old issue: https://bugzilla.mozilla.org/show_bug.cgi?id=551235. I'll check this once I get to my second monitor, but my immediate thought is that the problem is related to how Firefox itself behaves on Mac OS X.
jip-hop 0 solutions 3 answers

Yes, that looks like the exact same problem. However under Snow Leopard and Firefox 13 (if I remember correctly), I didn't have such problems with white bars on my second monitor. That means that Mozilla and Apple DID work well together at some point in history :P So we know the white bars don't HAVE to be there... I'm looking forward to your second monitor as well and hopefully you'll find out a fix for this :) thanks again, as an add-on causing a little white space is already a big improvement on not being able to use my portfolio at all any more!

Yes, that looks like the exact same problem. However under Snow Leopard and Firefox 13 (if I remember correctly), I didn't have such problems with white bars on my second monitor. That means that Mozilla and Apple DID work well together at some point in history :P So we know the white bars don't HAVE to be there... I'm looking forward to your second monitor as well and hopefully you'll find out a fix for this :) thanks again, as an add-on causing a little white space is already a big improvement on not being able to use my portfolio at all any more!
arp_fu 0 solutions 3 answers

So, I've been able to reproduce the issue -- it's intermittent and while some windows have that white strip on the top, some of them work just fine.

The bad news is that this strip is caused by Firefox itself, it's just the old bug with browser's own Fullscreen mode that reappeared.

In my case, it was enough to hit Cmd-Shift-F several times and move the window between desktops to get an absolutely normal window. Restarting Firefox also opened all its saved windows without a stripe.

I'm also using Tab Utilities extension (https://addons.mozilla.org/en-US/firefox/addon/tab-utilities/) which seems to somehow affect the way the top of the browser window is handled, so you may try using it as well.

So, I've been able to reproduce the issue -- it's intermittent and while some windows have that white strip on the top, some of them work just fine. The bad news is that this strip is caused by Firefox itself, it's just the old bug with browser's own Fullscreen mode that reappeared. In my case, it was enough to hit Cmd-Shift-F several times and move the window between desktops to get an absolutely normal window. Restarting Firefox also opened all its saved windows without a stripe. I'm also using Tab Utilities extension (https://addons.mozilla.org/en-US/firefox/addon/tab-utilities/) which seems to somehow affect the way the top of the browser window is handled, so you may try using it as well.