X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to disable instant tabs scrolling

Posted

Hello,

I did a little bit research on this problem and I was impressed that nobody asked for a solution on this annoying problem or it was just me who was unable to find it.

Basically there is a problem when I have lots of tabs in one window and I need to reach lets say the third tab from the right corner. I press arrow which point to the right 2 times and on the third time like 15 tabs are scrolled instantly which of course very effectively hides the tab that I was looking for. Extremely annoying, useless, stupid and impractical feature.

And who the hell was this clown who thought that this is an amazing idea?

Firefox 13

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

finitarry 157 solutions 2178 answers

I prefer to have all the tabs crowded together rather than scroll, so I prevented the scrolling from happening at all by putting this code into userChrome.css:

.tabbrowser-tab[fadein]:not([pinned]) { min-width: 16px !important; }

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96859 answers

You can look at these three prefs on the about:config page and change them according to your needs.

  • toolkit.scrollbox.clickToScroll.scrollDelay
  • toolkit.scrollbox.scrollIncrement
  • toolkit.scrollbox.smoothScroll

Type about:config in the location (address) bar to open the about:config page and press the "Enter" key, just like you type the URL of a website to open a website.
If you see a warning then you can confirm that you want to access the about:config page.

  • Use the Search bar at the top of the about:config page to locate preferences more easily
    • Preferences that have been modified and do not have the default value show as bold (user set)
  • Preferences can be reset to the default via the right-click context menu if they are user set
  • Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref

(the toolkit.scrollbox.verticalScrollDistance pref controls the behavior of scrolling the browser window and looks misplaced here)

Question owner

Thank you both for response!

cor-el, unfortunately those commands have no effect on this problem whats so ever.

Modified by annoyingscrolling

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96859 answers

If you click the scroll buttons twice is a quick row then they act as a page up and page down, so you need to wait a bit longer between clicking if you only want to move a few tabs.

Helpful Reply

Yeah, I kinda realized that. The point is that I don't have time to wait almost a whole second between every single click. When you have like 50 tabs opened and you need to quickly maneuver between them then it's a pain in an ass. When I click 10 times very quickly I expect to slide 10 tabs - not to go to the very end of those 50 tabs.

I just want to turn off or even better - to completely dismiss this page up/page down nonsense.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96859 answers

If you keep the scroll button pressed then auto-repeat will move more then one tab, so you only need to release the mouse button in time.

GCRaistlin 0 solutions 1 answers

Helpful Reply

So is there no way to disable this stupid feature?

DJGM1974 0 solutions 1 answers

The userChrome.css hack doesn't work. Tabs still scroll with this hack.