Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cant get FF to auto save .txt files like it does .doc files.

  • 9 replies
  • 2 have this problem
  • 3314 views
  • Last reply by ly92078

more options

when i change the action in the application section for a .doc file (ie open with... or save) it works. But if i try same for a .txt file it just opens the file and wont auto save it like a doc or rtxt file. Using FF 13.0.1. Windows 7.

Chosen solution

If you set the Boolean pref browser.altClickSave to true on the about:config page then you can force a download if you hold down the Alt key and left-click the link.

Read this answer in context 👍 1

All Replies (9)

more options

Hi,

One way you could try is to right-click the link and Save Link as.

more options

Thank you for the suggestion. That does work, but would be nice to just click once and have it go to the download file, as I can do with a .doc or .rtxt file.

more options

It could be because Firefox has the ability to render text files internally like with HTML. You can try Force Content-Type and obscure the content type, so that it is downloadable.

more options

Force Content Type did not seem to work for me. I might have not configured it correctly.

more options

The problem with using Force Content Type is that for every file whose content-type you want to change, you have to specify the path to that file first. It is easier just to right-click the link and choose save.

more options

The right click does work by pushing right click and then save for .txt files.

 It would be more convenient when downloading 30 or so linked txt documents to just press once on each link, which I can do if it is a doc or rtf document. 
And what would be even better would be to highlight the whole list of links at once!  Haven't found anything to do that.
more options

Chosen Solution

If you set the Boolean pref browser.altClickSave to true on the about:config page then you can force a download if you hold down the Alt key and left-click the link.

more options

Text files are usually send by the server as text/plain and that causes them to get displayed in a browser tab instead of offering to download the file.
You will have to use "Save Link as" in the right-click context menu or use the above mentioned method with holding down the Alt key and left-click.

more options

Thank you cor-el. That worked!