Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is my firefox constantly freezing?

  • 6 replies
  • 32 have this problem
  • Last reply by Oldron

more options

When I'm on websites (none in particular), the scrolling will randomly stop and I will not be able to close any tabs or the window..I have to use cont, alt, delete and force it to shut down...sometimes if I let it sit long enough (5+ minutes) it comes back but only for a short period of time...I have uninstalled Firefox and reinstalled, rebooted, restored, everything I could think of and nothing has helped...the continue and stop script message keeps coming up and heres what it says:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.


any help is appreciated...I'm not sure what else to do...Thank you

All Replies (6)

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"
more options

yup, all of that was already checked before I went into there...any other suggestions?

more options

You can try to reset Firefox.

Reset creates a new profile and tries to import some settings from the old profile leaving the old profile intact.

You can also try a completely new profile: "Basic Troubleshooting: Make a new profile":

more options

tried all of the things mentioned above....reset, made a new profile...and it still freezes when I open frustrating...I don't know how else to fix it?

more options

This can be caused by smooth scrolling that has been enabled by default in Firefox 13

  • Tools > Options > Advanced > General: Browsing: "Use smooth scrolling"
more options

Disable Adobe Flash helped me. FF 13.0.1, Flash 11.3.300.262, Win 2008 R2 64bit

Modified by Oldron