Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox cant open google after updating to 13.0.1

more options

I experience this after updating my browser yesterday. All the other sites work well. Only google.co.uk opens. Actually, none of google services (search, maps, gmail etc) is loading. It is working fine with no problem in IE. The proxy setting is fixed (no proxy), but this still didnt help. Scanning with antivirus didnt show anything aswell. Cleaning history and cookies didnt help as well as turning all extensions and plugins installed. Error console is also empty. Trying to open google just times out, even without showing any info that page is unavaible or anything. The weird thing is that entering google ip, the site works fine, so it must be the dns problem...

Chosen solution

I did try to flush dns earlier, no success. As for twitter page - it loads fine. EDIT: You mentioned spdy, so I went to config page, and turned spdy off. (network.http.spdy.enabled;false) and now google works as before.

Read this answer in context 👍 3

All Replies (4)

more options

Oh, and my hosts file is also 'empty'. Tried adding 209.85.148.139 google.com to the hosts file, still no success.

more options

hello, to test if this is an issue with spdy (a new protocol that was introduced in firefox 13 and is used on secure pages on google.com) or rather dns - does this page load successfully: https://twitter.com/firefox (twitter is also served via spdy)?

you could also try flushing your dns cache: www.wikihow.com/Flush-DNS

more options

Chosen Solution

I did try to flush dns earlier, no success. As for twitter page - it loads fine. EDIT: You mentioned spdy, so I went to config page, and turned spdy off. (network.http.spdy.enabled;false) and now google works as before.

Modified by Klemik

more options

hi. I also had this problem and I tried everything. I uninstalled ff then reinstalled it (*all my settings were saved but I had to download it via ftp cos IE wudnt let me download directly- pain in the neck are IE.) this didn't work. so don't try it. Its more stress than its worth! After reading thru this thread, i got a solution, but some of you may have overlooked this, I think. SOLUTION- Go to Tools/Options/Advanced -and if both SSL and TSL are checked then -DO NOT THINK THAT THIS IS NOT THE PROBLEM! which is what I thought at first, but IT IS! this is what I do and it works every time (but I often have to do it every time I start FF) first uncheck SSL, then try to open google, or other website that wont load, a page will load that says SECURE CONNECTION FAILED, then go back to Tools/Options/Advanced and check SSL again, then OK. Then go back to Failed page and press TRY AGAIN, and Voila!!!! page shud open. this works for any google related site! hope Iv been helpful, and lets just hope that this big bad jungle world we live in will change, and make things easier for us little ppl. x