X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube won't play in Firefox 13.

Posted

The newest version of Firefox, 13.0, seems to have a problem playing youtube videos. Whenever I go to youtube and try to play something I get a “There seems to be an error. Please try again later.” At first I thought it was a problem with youtube, and put in an error report with them. Youtube played fine on my earlier Firefox installation, and plays just fine on Google Chrome and IE, so the problem seems to lie with Firefox. In the past I have had other problems with updates to Firefox. One time I couldn’t see what was in my Google search box after updating. The next update seemed to take care of the problem. I cringe when I see that pop up box that says there is a new version of Firefox available. I wonder what favorite add ons won’t work with this one, and what other problems it might bring. That’s why I tend to wait for a couple of weeks to months before clicking the update button, hoping that maybe the bugs will have been worked out. I normally donate a little bit to programs and projects that try to improve my computer experience for free. Firefox has not given me a reason to donate. I have read the solution for uninstalling Realplayer and rolling back Flash, and this doesn't work for me. I use Realplayer all the time on my computer, and Firefox will leave before Realplayer does. If Firefox can't come up with a simple solution or fix then I guess Chrome is in my future.

Chosen solution

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox 13 are most probably caused by a recent Flash 11.3 update and/or a malfunctioning Real Player browser plugin.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Flash Plugin - Keep it up to date and troubleshoot problems

Adobe Flash plugin has crashed - Prevent it from happening again

Flash 11.3 doesn't load video in Firefox

Other, more technical information about these issues can be found under these Links:

http://forums.adobe.com/thread/1018071?tstart=0

http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html


Please tell us if this helped!

Read this answer in context 13

Additional System Details

This started when...

I upgraded to 13.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

Tobbi
  • Moderator
67 solutions 450 answers

Chosen Solution

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox 13 are most probably caused by a recent Flash 11.3 update and/or a malfunctioning Real Player browser plugin.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Flash Plugin - Keep it up to date and troubleshoot problems

Adobe Flash plugin has crashed - Prevent it from happening again

Flash 11.3 doesn't load video in Firefox

Other, more technical information about these issues can be found under these Links:

http://forums.adobe.com/thread/1018071?tstart=0

http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html


Please tell us if this helped!

Question owner

The Flash Player link solved the problem. Thanks Tobbi.

cvillakg2k1 0 solutions 2 answers

@BrotherofCats :: Can you please help me to as to exactly what you did to solve the problem facing the same issue here ... Many Thanks ..... I tried uninstalling and reinstalling flash it still dosent work.. Running firefox 13.0.1 on a PC .... Many Thanks

Edward222 0 solutions 1 answers

I have the same problem. Please tell me if you find an answer.

cvillakg2k1 0 solutions 2 answers

Helpful Reply

@Edward :: This worked for me ...

Turn off Web Download & Recording in RealPlayer

   Launch RealPlayer
   Click the RealPlayer icon in the upper left corner of the window and choose Preferences.
   Choose Download & Recording from the left hand panel
   Uncheck "Enable Web Download & Recording for these installed browsers"
   Click OK and close RealPlayer
   Restart Firefox 

Hope it works for you ...

@Tobi :: Many thanks pal one of the links helped me out .. :))

Modified by cvillakg2k1