X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

since upgrade to v. 13 Yahoo mail keeps getting "your session has expired"

Posted

Firefox automatic upgrade to ver. 13 today. now every 15 - 20 minutes my yahoo mail keeps popping up the message "Sorry, your session has expired. To protect your account, you need to confirm you account periodically. This only happens in FF ver. 13, IE & Chrome are fine

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:


EDIT: See also this post on page two of this thread:

Read this answer in context 4

Additional System Details

This started when...

FF was upgraded to Ver 13

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Win64; x64; Trident/5.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; Tablet PC 2.0)

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi jazzwineman, each Firefox update has security patches, which are a good reason to keep current even if new features are not of interest. As an IT person, you are familiar with controlling patch deployments in a controlled environment, but most users do not browse in a well-managed environment and need to keep as current as possible for security reasons.

Each beta of Firefox is tested for over a month, and you can read dozens of bugs filed and fixed (and sometime not able to be fixed) for each major release. Since Yahoo is a popular site, if this had been noted in testing as a widespread problem, it would have been fixed. However, based on the information in this thread, it is related to an interaction with stored data or custom settings or add-ons, the innumerable permutations of which are difficult to test prior to release.

Unfortunately, deleting prefs.js (or creating a new profile or using the Reset feature) removes all custom preferences, so we still do not have a specific culprit for this problem. Once one is identified, then we can figure out whether Firefox has a bug to fix, or whether we can find a more streamlined way to fix the settings/add-ons issue.

jazzwineman 0 solutions 23 answers

My point- if you can not identify a culprit, then why have users go through all these alterations. You should do the ethical thing and post that if you use yahoo, do not download or withdraw it from the market until you have it fixed.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi jazzwineman, it's not up to me to make release decisions for Mozilla, I'm just trying to help users here.

83 people having the same problem is a lot of people, so there probably is some common setting that we can identify and explain how to reset more precisely than blowing away the entire prefs.js file.

I can't do the testing myself because I can't replicate the error, so it's really helpful to have other users willing to try things. For example, rather than delete or rename prefs.js, it might be worth going into the about:config preferences editor, filtering the list for anything containing yahoo, and then resetting those preferences to their defaults.

lanefree 0 solutions 9 answers

Soo madddd!!! I got an e-mail from yahoo that told me to down grade back to firefox 12. Mozilla strongly states do not downgrade at any cost. I have had to profile delete on the last update and everything go screwed up so I am stuck until mozilla and yahoo smarten up and work together. This issue is far from solved.

lanefree 0 solutions 9 answers

Thank you jazzwineman!!! I have been silly enough in the past to follow the "solved" steps posted here only to then have even worst issues. Mozilla had another update over the weekend that did nothing to resolve the yahoo mail issue.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi lanefree, one step in this long thread identified to remove the problem was delete the prefs.js file, which stores custom settings. This does not require deleting an entire profile. I'm sorry to hear you did not find this thread before doing that.

As for whether to use Firefox 12 (or Flash 11.2, or any other outdated software), you have to decide for yourself whether the security vulnerabilities are sufficiently important to warrant avoiding it.

jazzwineman 0 solutions 23 answers

If the software is unusable for what you do, then whatever so -called security risks will have to be tolerated or people will have to go to another browser. It is silly to suggest they not be able to use their email and accept that as a reasonable answer. That is Microsoft type talk and clearly unacceptable. Having inexperienced users playing around in their computer doing things they don't understand is a setup for problems that will cost some, money to fix.

Modified by jazzwineman

Flyingwriter 0 solutions 5 answers

I am having essentially the same problem. I am in yahoo mail and click to open a message or send a message I have composed and I am asked to log in again with my password. Or I just click on a different category and I am asked to log in again and enter my password.

Yahoo support had me remove all my cookies and history but that didn't fix the problem. I was having no issue like this until Firefox 13. So the problem is with Firefox 13. I cannot return to version 12 because I cannot locate a place on the net to find a copy of 12.

TammeraF 0 solutions 2 answers

Well, I have the same problem...surprise surprise...lol It is so frustrating having to log in every few minutes...I did find that if I just hit reload, I dont have to log in...Now I dont understand all this mumbo jumbo about creating a new profile, and deleting this or that file, saving this or that file...I would just like Mozilla to fix the problem they created...create a patch...a fix...so that those of us that dont understand all this computer stuff in creating a new profile and such can go back to the ease of checking our email without having to log in every few seconds....Thank you thats all I have to say...lol

sfeinste 0 solutions 3 answers

Helpful Reply

I tried the suggestions here and was able to solve the problem - temporarily. Replacing prefs.js did it. HOWEVER, it didn't continue to work once I changed some of my settings.

I can now reliably reproduce the problem simply by toggling the proxy settings. If you go to Firefox->Options, go to the Advanced panel, then click on the Network tab, click on the Settings button under Connection (Configure how Firefox connects to the Internet). I believe the default is "Use System Proxy Settings", and when I have it set to that I have no problems with Yahoo mail. When I connect to my company's system via VPN software I need to use a proxy. Rather than have to go in and manually change this whenever I connect/disconnect with work, I typically have the setting as "Auto-detect proxy settings for this network". That works fine and gets me through the company proxy server, and up until Firefox 13 has not caused any problems. With Firefox 13, however, this setting causes the symptoms described in this post with Yahoo mail sessions expiring.

So I think the reason why removing prefs.js works is because the next time Firefox is started it will realize that there are no saved preferences and therefore will revert to defaults. It may be that people experiencing this problem had the auto-detect option selected for their proxy connection, so removing prefs.js effectively set it back and perhaps many such people don't actually need a proxy connection anyway.

My recommendation would be to check this proxy setting first before going down the path of creating new profiles or resetting all of your preferences. It's still just a workaround - hopefully Mozilla will have a real fix for this soon.

TammeraF 0 solutions 2 answers

Thank you....I checked the proxy settings and changed as you suggested and have not had a problem yet...So thank you...any easy temporary solution is appreciated much more than all the other mumbo jumbo....lol...no offense to those that suggested making a new profile...is that, well, Im blonde...hahahaha have good one everyone

techbutler 0 solutions 1 answers

proxy setting worked for me...go figure

Flyingwriter 0 solutions 5 answers

thanks for the input, sfeinste.

Well I tried to change my network connections settings from "auto-detect proxy settings for this network" to "use system proxy settings" as you suggested. I click OK but then when I restart Firefox 13 "auto-detect proxy settings for this network" has re checked itself. I tried it several times and I cannot get my choice "use system proxy settings" to stick.

Update, - I had to check OK twice to get the choice to stick. I will try it for a while and report back here if situation improved.

The whole this is very frustrating!

Modified by Flyingwriter

FFinCT 0 solutions 11 answers

I've had a similar problem with getting frequently booted out of AT&T / Yahoo web email, including with Firefox 13.0.1 recently. I've started to use Chrome more since this started happening, and I don't run into this issue (so far!) with Chrome.

Experimenting with Firefox proxy settings... I have switched to "Use system proxy settings" from auto detect. The setting itself stays in place on multiple boots of Firefox (it doesn't, in my instance, revert to the default). I also don't actually use a proxy. This settings change seems to help.

Yahoo has had a couple of server outages in my area (CT) within the last couple of weeks, and maybe this could be part of the issue. I experienced the problem this thread is about, though, even after the outages were "fixed." I now wonder how thoroughly fixed! And if some mild server instability interacts with something about v13 of FireFox.

UPDATE: I left the computer on overnight with Firefox running and the AT&T/Yahoo mail site open - it didn't log me out. Next experiment, I will set the proxy settings to "No proxy," restart Firefox, and see if the connection persists without being logged off.

UPDATE #2: After about half an hour, the AT&T/Yahoo mail site connection is still up using "No proxy." Previously, when I was having the getting booted out issue, it would do so in approx 5 minute intervals. Next experiment, I'll use "auto detect" proxy, restart Firefox and see what happens.

UPDATE #3: After 30 minutes, same results with "auto detect" - the AT&T/Yahoo mail site is still "up" without issue.

My tentative conclusion: I wonder if this issue is more related to AT&T/Yahoo and if in the last day or two something about their mail servers has been remedied, at least for my region? At least as part of the equation.

Meanwhile, I'm going to set Firefox to "Use system proxy settings" and leave it there for a day or more and see what happens, if anything.

Are others still encountering issues?

Modified by FFinCT

jazzwineman 0 solutions 23 answers

This is wrong to have so many people who you know are unfamiliar with their computers and settings and are not power users play around with settings they have no understanding of.

You want to talk about security- Firefox does not support and will disable the Symantec Intrusion Protection that is part of the most recent release of Symantec Endpoint Protection. I manage at current about 8500 workstations and yesterday alone that part of Symantec prevented hijacks from FakeAv's from infecting 9 computer. Your so-called new security updates to 13 will not do such.

Modified by jazzwineman

jazzwineman 0 solutions 23 answers

If it were related to Yahoo, then the same condition would exist with 12, which it does not

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Firefox does not support and will disable the Symantec Intrusion Protection that is part of the most recent release of Symantec Endpoint Protection.

This is off topic for session problems, but I'm curious: why/how does that occur?

FFinCT 0 solutions 11 answers

12 may have something in its design that didn't/doesn't trigger indigestion on the part of Yahoo's servers.

In any event, I no longer have the issue this thread started with and am hoping it stays that way. 13.0.1 is now consistently and solidly working for me with Yahoo, regardless of the proxy settings experiment, including what was the default setting.

Given recent Yahoo server issues that overlap the same timeframe as this thread, I just simply raise the possibility that problems at Yahoo could make it look like a Firefox build problem (a red herring).

I'm also not telling anyone that they should or shouldn't change their settings; I'm only sharing my experience.

jcanth 3 solutions 35 answers

The proxy settings seems to have done the trick..

If I use system proxy settings or no proxy, starting Firefox takes me to my Yahoo homepage, and e-mail without incidents.

As soon as I set it to Auto detect proxy settings and start Firefox, the login page appears again.

So I'll give it a try with System Proxy settings and see how it goes.

jazzwineman 0 solutions 23 answers

Why would be known to Firefox or Symantec. How is pretty simple- when 13 loads and checks plug-ins or extension is says it is not compatible and disables it and you cannot manually enable it either. Either tell me or I guess as I don't know why????