Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 13.0 ALWAYS Opens the "Welcome to Firefox" Page, Not My Home Page. What Will Actually Fix This, Please?

  • 23 replies
  • 12 have this problem
  • Last reply by cor-el

more options

I tried all of the advice in and there was no effect on the problem.

I tried the advice in, but again, there was no effect on the problem.

I even tried But, whether I set it to the "Default Page" or to a new home page, it doesn't matter...

Firefox 13.0 will still only open up to the "Welcome to Firefox" page.

Please help me. Is anyone looking at fixing this?

Modified by Duke SkyWatcher

All Replies (3)

more options

Mozilla's history is impressive and a big part of the reason I switched from IE a long time ago. And why I expected a better response than what I got.

How did more than a decade of bug reports and fixes get established? By someone, a lot of someones really, taking bug reports, and then more someones working on fixing the reported problems. Only after a bug report is taken can one figure that it is being looked at, worked on, and eventually fixed.

What happened here? A user reported a problem, and a set of useless knowledge base articles are posted. When those don't work (wasting hours of the users time), Mozilla blames it on the anti-virus software they used to know how to work with, and then just walked away. No bug report taken. No fixes being worked on. No solutions offered. Just attempts to scare (or persuade) the user into accepting the new buggy version.

Next, it'll be called a feature.

Modified by Duke SkyWatcher

more options

Well, here's the problem: what steps are needed to replicate the bug? It's obviously very rare and the developers can't track down something to change in Firefox without understanding what combination of add-ons and settings is causing it.

After the "you've updated" page is shown once, Firefox needs to flip a setting so it isn't shown again and for some reason that's not working. I think the suggestion about closing Firefox while the antivirus software is inactive is to test whether the AV software is preventing Firefox from saving changes to its settings file. Maybe that theory is completely wrong, but it's hard to rule out without trying it.

I agree that troubleshooting is a PITA, so there is a "Firefox Reset" as a new alternative for escaping from the majority of highly idiosyncratic issues. For many users that approach will be preferable, especially if they haven't built up a lot of add-on data. Refresh Firefox - reset add-ons and settings.

The volunteers here have lived through their own browser nightmares, and tend to be very blunt about problems and weaknesses in Mozilla products. No one is pretending that the annoying "you've updated" page is a feature. On the contrary, we're taking time away from answering posts about crashes, lost bookmarks, inoperable email, and other catastrophes to try to resolve this. Call fail if you like, but we're not blowing anyone off here.

more options

I would assume that you have some security software that is restoring files (e.g. .ini or .js) in the Firefox Profile Folder if you get that page each time Firefox is started.

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.


  1. 1
  2. 2