Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "Connecting..." goes on forever even if web page is already loaded (With NoScript addon)

  • 5 replies
  • 4 have this problem
  • 7 views
  • Last reply by gbh22

more options

The "connecting ..." green circle goes on forever, even though web pages loaded correctly, and no problem surfing *all* web sites. I suspect NoScript addon blocks some of the contents. At those web sites, if I allow NoScript to load all ("temporary allow all" it will stop this problem and no more green circles. But the 'Allow All" must apply to all tabs. Applying to only one tab won't do. Even if only one tab is partially blocked by NoScript, the green circle will be on ALL the tabs. Request Firefox fix this in future version. My system Info: Win7 Home Premium 64-bit, 8G memory, Firefox 12. Addon: NoScript 2.4.3 (it auto updates)

The "connecting ..." green circle goes on forever, even though web pages loaded correctly, and no problem surfing *all* web sites. I suspect NoScript addon blocks some of the contents. At those web sites, if I allow NoScript to load all ("temporary allow all" it will stop this problem and no more green circles. But the 'Allow All" must apply to all tabs. Applying to only one tab won't do. Even if only one tab is partially blocked by NoScript, the green circle will be on ALL the tabs. Request Firefox fix this in future version. My system Info: Win7 Home Premium 64-bit, 8G memory, Firefox 12. Addon: NoScript 2.4.3 (it auto updates)

Chosen solution

Try the NoScript forum if it is a problem with NoScript blocking content.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

Try the NoScript forum if it is a problem with NoScript blocking content.

more options

I did the about:config on "network.http.max-connections" from 256 to 30 as advised somewhere here in the forum. I also disabled as well JavaScript. With both, no solution. However ... NoScript updates itself today, magically, solving this problem. NoScript auto updates today Jun04/2102, from 2.4.3 to 2.4.4 today. (Java Script is still enabled). Solved! P.S. I'll try to change back value from 30 back to 256 on "network.http.max-connections" in about:config. If problem is still there, I'll change it back to value 30. Hope it is all NoScript problem.

more options

Well 'solved' too early. Apparently, updated NoScript right there solved the problem *one time* only. When I close Firefox and open it again, the problem still there. I proceed to change about:config "network.http.max-connections" from 30 to 256. Close Firefox and reopen. No good. Change it back from 256 to 30. Close and reopen. No go. No solution here. IMHO,if NoScript blocks something, Firefox should time out and rid of that green circle ("Connecting ...") in the first place.

more options

I’ve seen several different discussions about this issue, and none of them have a real solution to it. It affects too few users for FF Support to get a handle on what the issue is. Here are links to some other discussions. https://groups.google.com/forum/?fromgroups#!topic/mozilla.support.firefox/M-fmY6bbCE8 This user has a similar issue, and is blaming a particular site: http://support.mozilla.org/en-US/questions/941659 Several of the users posting here seem to have the same issue: http://forums.mozillazine.org/viewtopic.php?t=2322845&f=38

I have had this problem fairly consistently in FF7 and in FF8, on my PC at work. I usually have several FF windows open with multiple tabs open in each.

FF works fine, but after some time has gone by, when I click a link or try to refresh a page, the Connecting issue appears. When one page (tab) does this, all the pages do it and nothing will load or reload in FF. Note that I often have IE pages open as well, and they continue to work. The only solution for me has been to go to Task Manager and kill the Firefox process. Then when I open Firefox it offers to restore the pages (and includes an unnecessary apology). I restore the pages and everything is back to working fine.

When I leave for the day, I leave my PC on and logged in, and after some time the screen locks. In the morning I log in to unlock the screen and begin working. This is when the issue most often appears.

This morning, when the issue started, I went to Error Console and found these warnings. This list goes on for several screenfuls. All of the errors are at nyt or nytimes URLs. Most of them have a timestamp of 7:27 – 7:51 last night. The rest are at 8:02 this morning, which is probably when I first clicked a link on an FF page. Not that I had logged in (unlocked) the PC around 7:30, and no errors were logged until I tried to click something.

Timestamp: 11/29/2012 8:02:06 AM Warning: Error in parsing value for 'background-image'. Declaration dropped. Source File: http://css.nyt.com/css/0.1/screen/common/modal/nytModal.css Line: 199

Timestamp: 11/29/2012 8:02:06 AM Warning: Error in parsing value for 'background-image'. Declaration dropped. Source File: http://css.nyt.com/css/0.1/screen/common/modal/nytModal.css Line: 203

Timestamp: 11/29/2012 8:02:06 AM Warning: Error in parsing value for 'background-image'. Declaration dropped. Source File: http://css.nyt.com/css/0.1/screen/common/modal/nytModal.css Line: 207

Timestamp: 11/29/2012 8:02:06 AM Warning: Unknown property '-moz-box-shadow'. Declaration dropped. Source File: http://css.nyt.com/css/app/facebook/newsletterPrefs.css Line: 17

Timestamp: 11/29/2012 8:02:09 AM Warning: Unknown property '-moz-border-radius'. Declaration dropped. Source File: http://www.nytimes.com/ Line: 6

more options

When I said, "Not that I had logged in (unlocked) the PC around 7:30 . . .", I meant, ''Note that I had logged in (unlocked) the PC around 7:30 . . ."