Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't know how to open this adress, because the protocol (javascript) isn't associated with any program

  • 16 replies
  • 4 have this problem
  • 4557 views
  • Last reply by cor-el

more options

How to solve this problem?

Chosen solution

I don't try Safe Mode.

But, in about:config - I have something change and error disappeared. Now Firefox will work normal!

I attach screenshot, My javascript configuration.

Thanks guys!

Read this answer in context 👍 1

All Replies (16)

more options

see if this is helpful : Register protocol


thank you

more options

Don't understand how to solve :(

more options

What are you doing when you get that error message?

Are you typing or pasting code in the location bar or do you get it when visiting a website (in that case please post a link if possible)?

more options

If I visit anything websites where used javascript - I get this error!

For example, try to open CodeIgniter guide (http://codeigniter.com/user_guide/) or just open http://google.com and get few copies (windows) of this error

Modified by cor-el

more options

Make sure that you do not block JavaScript

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

That link for codeigniter apparently points to something that does not exist. I get a 404 Not Found error.

more options

Remove from url ")". Sorry, correct link is http://codeigniter.com/user_guide/

more options

Somebody can show me parameters in about:config menu? Beforehand thanks!

more options

Remove the trailing ')' in that link to fix it.

more options

It is better to reset the javascript.options.strict pref to false to avoid getting a lot of messages in the error console.

Did you try Safe mode?

more options

Chosen Solution

I don't try Safe Mode.

But, in about:config - I have something change and error disappeared. Now Firefox will work normal!

I attach screenshot, My javascript configuration.

Thanks guys!

more options

Ah, I missed that the network.protocol-handler.external.javascript was set to true.

Yes that makes Firefox display that error if there is no application to handle JavaScript present.

more options

None of the links on that codeigniter page are javascript links. Javascript links begin with "javascript:", and no links on that page are like that.

more options

There is one:

<div id="nav2"><a name="top"></a><a href="javascript:void(0);" onclick="myHeight.toggle();"><img src="images/nav_toggle_darker.jpg" width="154" height="43" border="0" title="Toggle Table of Contents" alt="Toggle Table of Contents" /></a></div>
more options

Oh, I see. That one works, however.

more options

The onclick is done in such a case.
The href="javascript:void(0);" is only meant as a placeholder and doesn't need to be (shouldn't be) there (some pages use href="#").