Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My Shockwave Flash plugin for Firefox (& IE) causes browser/computer to crash & reboot, but only for vers. 10.2 +. At 10.1 & below, no issues. Any fix?


I've had this persistent problem of Shockwave Flash crashing my system and causing an automatic reboot of my PC as soon as I try to play any flash videos (no matter which browser, actually). However, as long as I keep my flash at version 10.1 and don't update it, it works okay. The problem is, how long can I keep it like this before some future tweak of general website flash sites prevents even this from working???

I want to know if there's a fix so that I can install future versions of the Shockwave Flash plugin and actually get it to work so I don't have to use such an antiquated version of Flash anymore (gag, even though I say this, I loath Flash, it's so clunky in any version, I wish websites would switch to some other video standard already).

If anyone has an answer, please let me know. (My computer runs Windows XP with Firefox 12, by the way. Oh, and I'd love it if there was a way to get Firefox to work on the iPad, Safari is such a bare-bones, childish browser, it has almost no useful add-ons or personalized functionality at all.)

Chosen solution

I just noticed that in the subject line of your post you indicate the ActiveX version of Flash for IE causes the same problem. I wonder whether there might be a problem with your graphic card driver software. Have you checked for firmware updates?

Read this answer in context 2

Additional System Details

Installed Plug-ins

Shockwave Flash (this one works, at least for now)


  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

  • Top 10 Contributor
2366 solutions 20923 answers

Helpful Reply

You mention 10.2+. Flash is now up to 11.2. Have you tried that version?

Have you noticed problems with any other plugins (e.g., Windows Media Player, PDF reader, etc.)?

Could you check on the plugin process isolation feature in the about:config preferences editor:

- Type or paste about:config in the urlbar and press Enter; click the button promising to be careful.

- In the filter box, type or paste dom.ipc and pause while Firefox filters the list.

By default, dom.ipc.plugins.enabled should be set to true (and not bolded) to run the Flash player in the plugin-container.exe process rather than the firefox.exe process.

If yours is customized to false, try double-clicking to reset it to true and test again. (You might need to restart Firefox in order for this to take effect; I'm not sure.)

String 1 solutions 15 answers

Fleabutt, Upgrade your shockwave flash plugin from authorized site such adobe. If possible check for infection also.

  • Top 10 Contributor
2366 solutions 20923 answers

Chosen Solution

I just noticed that in the subject line of your post you indicate the ActiveX version of Flash for IE causes the same problem. I wonder whether there might be a problem with your graphic card driver software. Have you checked for firmware updates?

Question owner

Thanks for the posts! That was quick, guys!

Okay, I'll respond in order. Yeah, I tried updating to newer versions of the Flash plugin in the last couple of years sometimes when I was asked, but the problem remained (the last attempt was 6 or 8 months ago after I did a recent Windows XP reinstall). My system would crash if I ever played any flash-based videos, even if I was watching a saved .flv video on my PC. However, I haven't tried installing the latest version yet and haven't bothered with newer updates for over half a year, given my skepticism of it ever working, heh.

I haven't had any problems with other plugins at all, Adobe Reader included. They all work fine. As for Windows Media Player, I've switched to a faster running version called ~Media Player Classic Home Cinema~ you can get online for free with the CCCP codec pack (doesn't have all that extra crap Microsoft keeps piling on). Other video players I have (like JetAudio, VLC, etc) also work fine, except for doing flash, obviously (unless I stay at vers 10.1).

I'll take a look at that plugin-process isolation feature and see what I find out, it sounds interesting!

As for where I get my updates from, I have tried it from the Adobe site itself - no joy, unfortunately. And as for a virus problem, since this problem continued right after I finished reinstalling Windows XP on a brand new C drive awhile back, that isn't a factor here, I'm fairly certain.

Finally, the observation that it might be my video card hardware/software that might be the problem is the most intriguing. Thanks for that one! I'll look into seeing if there's a newer firmware update for it, I never thought of that. I currently run a Radeon HD 4650 AGP card with two 24" wide-screen monitors (it's a replacement card for my previous ATI card that died on me a couple of years ago after its fan quit).

I'll post results when I have some.

  • Top 10 Contributor
  • Moderator
10754 solutions 96797 answers

Did you try to disable hardware acceleration in the Flash player?

See also:

Flash "Display settings" window:

Question owner

Hi again everyone!

And nope, I didn't think of that idea regarding hardware acceleration, though it's certainly an interesting one. And I didn't realize there was a Flash Player help page. Nice to know.

But guess what? PROBLEM SOLVED!

It turned out *jscher2000's* suggestion regarding my video card hardware software/firmware was the correct one! I went to the ATI website with the Radeon drivers site (now AMD, since they bought that company out) and got a newer Catalyst driver for my video card (Catalyst version 12.4, it turns out) and installed it, since it has newer functionality with Flash, according to some of the literature I came across. Then I updated both Shockwave and Flash to the newest versions this time and tested them out on the NASA TV website, and voila, no crashing!

It actually works! So nice.

So to *jscher2000*, I love you, man! And thanks to everyone else, too.

(I love it when a plan comes together. A-Team quote.)

Modified by Fleabutt

String 1 solutions 15 answers

Helpful Reply

Good Luck and always welcome :)