X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Amazon https does not load properly

Posted

I cannot access my Amazon account (using https) with Firefox.

Images do not load when using https. As the "Continue" button is an image, it does not appear on the page. This only happens with Amazon (.com, .co.uk and .fr) and no other secure website.

To access my Amazon account, I have to use IETab, IE9 or Chrome, as the problem only exists with Firefox.

I have restarted with all add-ons disabled: no change. I have updated all the plugins: no change. I do not use any "https-only" add-on.

This problem used to happen very occasionally and would disappear, but it is now permanent.

I see other Firefox users have been reporting the same problem for at least a year now, so this is not unique to me.

Any suggestion welcome...

Additional System Details

Sites Affected

https://amazon.com

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Picasa plugin
  • VLC media player Web Plugin 2.0.0
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Google Update
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPWLPG
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned in the following articles:


Check and tell if its working.

Question owner

Thanks for the suggestions, mha007.

I have cleared the Cookies, Cache, Network Cache and History. No change.

Attached pics show my Amazon screen with FF12 and with IETab.

Any other suggestion? TIA.

Modified by Crimbo

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned in the following articles:

Check and tell if its working.

Question owner

I have applied the suggestions shown on both pages, but no improvement.

  • JavaScript is enabled and not blocked.
  • AdBlock Plus is disabled on all Amazon pages (https page does not load properly even with FF in safe-mode).
  • Default image permissions is set to 1 in about:config.

Funnily enough, the Amazon page looks somewhat better (but still incomplete) when viewed with No Style (see att. pic).

If the problem was caused by one the the settings shown on the pages above, wouldn't all the Amazon pages be affected, rather than just the secure (https) page?

Thanks for your help.

Hasan 477 solutions 5600 answers

Are you seeing this problem on other https websites ??

Also see this article -> Websites don't load - troubleshoot and fix error messages

Check and tell if its working.

Question owner

No, the problem exists only on Amazon and exists on all Amazon sites I visit and only when I want to access my account, i.e. when using https:

I have no problem when banking online or when accessing other secure pages or websites. There is no error code or message. The page simply loads as shown the att. pic. above.

  • No proxy in use.
  • Windows own Firewall.
  • Cookies accepted.
  • Third-party cookies accepted.
  • Remember History.

Again, thanks for your help :)

Hasan 477 solutions 5600 answers

After you get access to your account on Amazon sites, check in your Amazon Account's Profile & Settings if there's anything you can do from there which causes the Display & Content changes on Amazon sites.. (like facebook settings as described below & shown in the attached screenshot)

originally suggested by Cor-el: "Some sites like facebook have a setting to force a secure connection.

Check and tell if its working.

Modified by Hasan

Question owner

I cannot find any similar setting on my Amazon account (accessed via IETab).

I did have a "https-where-available" add-on installed once, but I removed it because I didn't like the way it was behaving. Is it possible there is a remnant of it somewhere forcing Amazon to behave this way?

I have just remembered another site which also shows no picture or style when viewed with FF and it's not a secure site (pics att.). I use it so rarely that it didn't come to mind when I first posted here. I have set it to default to IETab when I want to read it.

Maybe there is a commonality somewhere...?

Sorry, I'm not very tech-minded. I see my laptop as I see my car: I want it to work with minimal interference on my part and I avoid having to look under the bonnet whenever possible! :)

Hasan 477 solutions 5600 answers

-> Create a New Profile to check if your current profile is causing the problems, as described in this article -> Basic Troubleshooting - Make a New Profile

  • Now start Firefox using this newly created profile.

-> IF that New Profile works then you can recover your History, Bookmarks, Passwords,etc. from the Old Profile, as described in this article -> Recovering important data from an old profile

Check and tell if its working.

markgrindrod 0 solutions 5 answers

Hi there. I have the identical problem. Any success in resolving the issue?

Question owner

Hello there. The problem seems to have disappeared since updating to FF13.0.1 last week.

Until then, and despite the helpful suggestions made here, the problem had not been resolved and I had given up trying to get to the bottom of it.

markgrindrod 0 solutions 5 answers

Hmm. That is interesting as the problem seemed to start for me with the update now that I think about it. Perhaps I'll try a reinstall. Glad you are up and running again.

markgrindrod 0 solutions 5 answers

No luck - I'll switch to safari for my Amazon shopping!

Question owner

Well, I don't want to forget about it just yet. The problem was intermittent for a long while before it became permanent and I cannot help but think it will reappear sooner or later... I hope you'll get to the bottom of it.

Hasan 477 solutions 5600 answers

Start Firefox in -> Troubleshoot Firefox issues using Safe Mode to check if your add-ons/extensions or hardware acceleration are causing the problems.

Check and tell if its working normally while using Firefox in Troubleshoot Firefox issues using Safe Mode.

markgrindrod 0 solutions 5 answers

Thanks for the helpful reply. I have tried the Safe Mode option but the problem persists. I will have a look at the article you recommend.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.


You can try to reset Firefox and create a new profile.

cnrockit 0 solutions 3 answers

I have the same problem with Amazon, Audible, Javari etc All the same supplier. There's obviously something in common with their web page construction which isn't browser friendly.

A lot of long-winded complicated work-arounds have been suggested to try out but none with a FIX after all that faffing around, for the average user.

I've had the same problem for the past 5? Firefox updates and the latest 3.1 is no different. All and only the Amazon group https pages are affected. I've not encountered this problem elsewhere.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

griwol 0 solutions 2 answers

Helpful Reply

Solution: There is problem with the SSL-Certificate of the Amazon images Server The SSL Website of Amazon want to load a Javascript form https://images-na.ssl-images-amazon.com and this gives an Javascript error in FF: fwcim is not defined Quelldatei: https://www.amazon.de/gp/css/homepage.html?ie=UTF8&ref_=topnav_na Zeile: 902 To solve this error open the page https://images-na.ssl-images-amazon.com/images/G/03/x-locale/common/login/fwcim._V182746877_.js direktly. FF will show a certifacte problem (see grafik). trust the site and add the Server to the trustet sites and all will work.

Perhaps it is only a problem of Firefox, because IE and Chrome will work. It's a COMODO certificate.

Wolfgang

Modified by griwol