Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I lengthen or extend the name of bookmarks in the bookmarks toolbar?

  • 6 replies
  • 1 has this problem
  • 238 views
  • Last reply by Eric Juneau

more options

My bookmarks toolbar abbreviates the names of links by adding ... or ellipses at the end. Is there a way to toggle Firefox so that it does not do this? I want to display the entire name of my bookmark, no matter how long it is.

My bookmarks toolbar abbreviates the names of links by adding ... or ellipses at the end. Is there a way to toggle Firefox so that it does not do this? I want to display the entire name of my bookmark, no matter how long it is.

Chosen solution

Just to make sure the folder is located in the correct place, you can open your currently active profile folder using:

Help > Troubleshooting Information > "Show Folder" button

Your chrome folder should be in that profile folder in order for Firefox to find it.

You might also need to add !important to the rule:


toolbarbutton.bookmark-item { max-width: 50em !important; }
Read this answer in context 👍 1

All Replies (6)

more options

Of course, if you do this, you will run out of space quickly... I generally add pages to a folder on my Bookmarks Toolbar; that gives you much more space. But I digress.

The toolbars are governed by internal style rules, and here is the culprit:


toolbarbutton.bookmark-item { max-width: 13em; }

Firefox allows you to override such internal style rules by placing your own rule in a userChrome.css file or using an add-on such as Stylish. You might want to try 50em to accommodate really long names.

For more information on editing the userChrome.css file, see the links in this thread: How to change urlbar font size/color on linux firefox? | Firefox Support Forum | Firefox Help.

Stylish involves more steps initially, but is useful for dynamic editing and testing of more complex changes. Examples of how to use Stylish can be found in these threads: Ink wasting because pages with dark backgrounds still print despite background print checkbox being unchecked; Using Foxfire 5 in Win 7 I lost the highlighting of current BM in use (as compared to Win XA FF 5) .

Can you find a size that works well for you?

more options

Just in case you meant the drop-down menu of bookmarks, rather than the bookmarks displayed horizontally across the Bookmarks Toolbar, you can adjust the width by overriding the max-width in this rule:


menu.bookmark-item, menuitem.bookmark-item { min-width: 0; max-width: 32em; }
more options

The userChrome.css solution didn't seem to do anything. I created the chrome folder and userchrome.css file myself under C:\Users\<myusername>\AppData\Roaming\Mozilla. I put in these lines:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

toolbarbutton.bookmark-item {

 max-width: 50em;

}

I restarted firefox, but nothing changed. The link to editing userchrome.css wasn't very helpful. Is this even still used? All the resources I found, none were dated past 2009.

more options

Chosen Solution

Just to make sure the folder is located in the correct place, you can open your currently active profile folder using:

Help > Troubleshooting Information > "Show Folder" button

Your chrome folder should be in that profile folder in order for Firefox to find it.

You might also need to add !important to the rule:


toolbarbutton.bookmark-item { max-width: 50em !important; }
more options

Yes, you need to add the !important; flag.

For other locations you can use rules like this (adjust the max-width to suit your needs, either in px or in em).

#bookmarksMenuPopup .bookmark-item { max-width:500px!important; }
#personal-bookmarks toolbarbutton.bookmark-item { max-width:100px!important; }
#personal-bookmarks menupopup .bookmark-item { max-width:500px!important; }
#BMB_bookmarksPopup .bookmark-item { max-width:500px!important; }
.bookmark-item[livemark] .bookmark-item { max-width:none!important; }
more options

Yes, that worked. I had it in the wrong folder, and I needed the !important tag. Thank you very much.