X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Ask.com and Firefox home page redirect search issue

Posted

Hmm. I'm at the end of my tether now and can't work out to solve this issue.

I know I have installed Ask.com by accident and the initial issue was Ask.com became the default homepage. I've reset that to Firefox fine

I've un-installed the Ask.com file from the control panel.

Second issue was url search result returning ask.com. This too is fixed.

However when searching from the about:home page using the search box the result returns ask.com listings.

In about:config the following two results are listed for Ask.com

Preference name: extensions.wrc.SearchRules.ask.com.style

Value: .WRCN {display:none} #yui-main .tsrc_vnru .title + .WRCN, #yui-main #teoma-results .title + .WRCN {display:inline !important; background: url("IMAGE") right no-repeat}

Preference name: extensions.wrc.SearchRules.ask.com.url

Value: ^http(s)?\:\/\/(.+\.)?ask\.com\/.*

both are.

Status: user set

Type: string

What do I need to do to fix my Fox?

Thank you..

Modified by sgotts500

Chosen solution

You can also reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Read this answer in context 12

Additional System Details

This happened

Every time Firefox opened

This started when...

I realised ask.com had snuck in under the radar

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • VLC media player Web Plugin 2.0.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Version 0.9.19, Copyright 2006-2012 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Irritating, isn't it? The solution is posted in this thread (about halfway through Matt_G's post): how to make firefox 12 homepage search using google | Firefox Support Forum | Firefox Help. Any luck?

Question owner

thank you. I've tried it but I still have the same redirect issue

excuse my ignorance I've never used scratch pad before. Do I copy the whole script as shown? .

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

Chosen Solution

You can also reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

Thank you cor-el. Problem seems to be fixed. Would you be able to explain what I've changed and how the fix worked its magic?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

You're welcome.

A program or maybe a Firefox extension seems to have changed the about:home settings that are stored in the chromeappsstore.sqlite file in the Firefox Profile Folder to use Ask.com for searches.
The above posted steps have reset the search engine to the default and hopefully that stays.

qstn1 0 solutions 1 answers

I've just posted two questions about the same problem. I've tried uninstalling the Ask toolbar. How do I uninstall the Ask.com file from the control panel, sgotts500 (or anybody else)? How do I fix the URL search result that returns Ask.com, sgotts500 (or anybody else)? How do I find the location bar to open the about:config page as cor-el has just suggested?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

Helpful Reply

The location bar is the address bar on the Navigation Toolbar where you type the address (URL) of a web page to go to.

Question owner

I went to add/remove programs. Ask.com wasn't listed under the 'A' section in the list but under the name of the program it was installed with. This was my initial problem as all solutions pointed toward removing the Ask program in 'add/remove programs' but I couldn't find it straight away. Once I removed the program for the toolbar the URL issue went away however the Firefox search issue remained. This is a nasty little program which wants to hang around even when it's been removed from the program list.

As per the link Cor-el provided 'about:config' allows you to access the inner workings of Firefox. First off I typed in Ask.com to list all occurances of it within Firefox.

I didn't know what the list meant but it allowed me to find out that Ask.com was indeed upto something in Firefox

Having removed the Ask.com program I still had the issue of the search redirect in Firefox. I went back to about:config to search again for Ask.com and found the two entries listed in the first post. I posted my question on here and so far with Cor-el's help the issue is resolved.

Other replies to this problem advised typing ask and/or ask.com in the bar to find the offending entries. Unfortunately there are lots of instances of ask within normal entries such Task or 'browser.helperApps.neverAsk.openFile'.

Modified by sgotts500