Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Internal intranet sites require authentication despite ntlm addition

  • 6 replies
  • 3 have this problem
  • 5442 views
  • Last reply by philipp

more options

Despite adding *.domainname.com to the NTLM list in the relevant config section, we still get prompted for user auth to internal intranet sites using Firefox - is there something else we need to change or a way around this please?

All Replies (6)

more options

refer to this article on how to enable ntlm authentication in firefox: Firefox asks for user name and password on internal sites

more options

Thanks for your quick response - we tried this, but still the internal sites still prompt for authentication, even after re-starting all isntances of Firefox, so am thinking there must be another item to config or a bug perhaps?

Thanks Peter

more options

maybe the *-wildcard doesn't work and you'd have to enter all the subdomains where it shuold apply manually, like "site1.example.com, site2.example.com, site3.example.com"

more options

Hi madperson, you are absolutely right, firefox does not support wildcards, and through testing various combinations, we now see this working, thanks v much for you input and help here, much appreciated!

more options

Hi - is there any solution to this issue? I have tried modifying a few other settings (.ntlm-auth.trusted, negotiate-auth.trusted and .delegation) but it is still prompting me for a username and password. I am currently using Firefox 3.5.1 and cannot upgrade to another version due to compatibility issues with our other apps.

more options

hello ntran, support for wildcarts was added in firefox 13 and the most recent extended-support releases (refer to bug #452781). unfortunately the 3.x branch of firefox isn't supported any longer, so this change won't be backported to this prior version.