Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting rid of "URGENT!" message Firefox no longer supports your operating system.

more options

I'm using Firefox 12.0 beta with Windows 2000. I'm aware that Win2K is no longer supported but Firefox version 12 will continue to function whereas newer versions will not.

 That is all O.K.  I just want to get rid of the nag reminder, "Software Update    URGENT!       Firefox no longer supports your operating systems version and will be vulnerable to online attacks."

All Replies (1)

more options