X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Hey all, I just downloaded Firefox 9 but I guess this doesn't work with Mac OS 10.4.11? If not, any suggestions on how I can get awesomescreenshot.com? tx

Posted

I downloaded Firefox 9, put in Application folder yet every time I go back to awesomescreenshot.com to download, still says I am using an old version of Firefox. So frustrating. Would LOVE any help!!

Chosen solution

Firefox 3.6.28 is the latest version of Firefox that works on 10.4. Firefox no longer works with Mac OS X 10.4 or PowerPC processors You unfortunately have a PPC processor, so the only way you can use modern software is to purchase a new PC. Or, you can try using http://www.floodgap.com/software/tenfourfox/. But please note that you will be using a community project that may or may not work.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • WebEx General Plugin Container Version 166
  • npmnqmp 071303000006
  • Java 1.3.1 Plug-in
  • iPhoto6
  • 1.0.30715
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.1 r85
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6.28

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Chosen Solution

Firefox 3.6.28 is the latest version of Firefox that works on 10.4. Firefox no longer works with Mac OS X 10.4 or PowerPC processors You unfortunately have a PPC processor, so the only way you can use modern software is to purchase a new PC. Or, you can try using http://www.floodgap.com/software/tenfourfox/. But please note that you will be using a community project that may or may not work.

Question owner

Thanks, Tyler. I was afraid that might be the answer :) Oh well, time to get a new Mac. Thanks, again!