X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why won't the newest version of Adobe Flash Player install on my Firefox?

Posted

I am trying to install the newest version of Adobe Flashplayer onto my Firefox (the Adobe version is 11.1.102.62) but it will not let me. It allows me to download the installer, and then it installs until about 45% and then says "Please close the following programs to continue" and it says Firefox is the only one open. I have closed Firefox and made absolutely sure it's not running, but it still says that it is running and refuses to install. Is there something I am doing wrong? The Firefox version is 11.0 and I use Windows 7.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 3.5.0f6
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • 4.1.10111.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Pando Web Plugin
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • MSN® Toolbar
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Solutions
Follow these steps to install the correct version of Flash Player:
Verify that your computer meets the system requirements for Flash Player
Determine whether an older Flash Player version is already installed your computer
Download and install the latest Flash Player version
Verify that installation is complete
Uninstall the older Flash Player version (if the installation is not successful for any reason)
Try more solutions (if necessary)

Tristan C. 11 solutions 109 answers

You might want to upgrade your Firefox version and see if you keep getting this error message. Let me know how it goes.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

You can find the latest Flash player for Firefox on this page.

For Firefox on 64 bit Windows, you need the 32 bit Flash version version because Firefox is a 32 bit application.