X
Tap here to go to the mobile version of the site.

Support Forum

I recently updated to firefox 12, the search engine in the homepage redirects to yahoo when I use it. How do I fix this as it is really irritating?

Posted

The default search engine on the default homepage in firefox is redirecting me to yahoo and I can't figure out why or how to fix it, I've done all of the suggestions and solutions suggested in earlier posts and versions and I don't know how to fix it.

The default search engine on the default homepage in firefox is redirecting me to yahoo and I can't figure out why or how to fix it, I've done all of the suggestions and solutions suggested in earlier posts and versions and I don't know how to fix it.

Chosen solution

Do you mean the search engine on the about:home page?

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

See also:

Read this answer in context 3

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to firefox 12

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • VLC media player Web Plugin 2.0.0
  • Pando Web Plugin
  • Shockwave Flash 11.1 r102
  • 4.1.10111.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • NPWLPG
  • npdnupdater2
  • npdnu
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Swarnava Sengupta 482 solutions 3210 answers
Install this addon and try * https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Question owner

Thanks for the suggestion but I'm afraid that didn't work either, yahoo is worse than the US government in the sense of not wanting to acknowledge that no one cares and is still clinging to the hope that this will work. ;)

Thanks for the suggestion but I'm afraid that didn't work either, yahoo is worse than the US government in the sense of not wanting to acknowledge that no one cares and is still clinging to the hope that this will work. ;)
SafeBrowser 543 solutions 2390 answers

You appear to have some Yahoo product(s) installed. Yahoo may have "piggy-backed" onto your system when you installed some third-party software on your system; always look for an opportunity to not install extra items or look for a custom install option when installing software or software updates.


  1. Remove Yahoo Toolbar (if you have it installed):
  2. Reset your home page (if the Yahoo search page is displayed when starting Firefox): http://support.mozilla.org/en-US/kb/How+to+set+the+home+page
    • You can reset to the default by clicking "Restore to default" on Options > General > Startup > Home page. Be sure to set "When Firefox starts" to "Show my home page" on that same panel.
  3. Reset your Location Bar search engine (if typing a few words in the URL/Location Bar takes you to Yahoo search):
  4. If Yahoo is shown in your Search Bar and you want to remove it:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

You appear to have some Yahoo product(s) installed. Yahoo may have "piggy-backed" onto your system when you installed some third-party software on your system; always look for an opportunity to not install extra items or look for a custom install option when installing software or software updates. #Remove Yahoo Toolbar (if you have it installed): #*Yahoo's uninstall instructions --> http://help.yahoo.com/l/us/yahoo/toolbar/toolbar8/general/general-07.html #*http://support.mozilla.org/en-US/kb/Uninstalling+add-ons #*http://support.mozilla.org/en-US/kb/Cannot%20uninstall%20an%20add-on #*http://kb.mozillazine.org/Uninstalling_toolbars #Reset your home page (if the Yahoo search page is displayed when starting Firefox): http://support.mozilla.org/en-US/kb/How+to+set+the+home+page #*You can reset to the default by clicking "Restore to default" on Options > General > Startup > Home page. Be sure to set "When Firefox starts" to "Show my home page" on that same panel. #Reset your Location Bar search engine (if typing a few words in the URL/Location Bar takes you to Yahoo search): #*type '''''about:config''''' in your Location Bar, like typing a web site address, and press the Enter key #*ignore warning and choose to continue #*in Filter, type '''''keyword.URL''''' #*in lower part of screen, if it is '''bold''' and shows "'''user set'''", right-click keyword.URL and choose "Reset" #*in Filter, type '''''Yahoo''''' #*any items in lower part of screen in '''bold''' and showing "'''user set'''", right-click and choose "Reset" #*close about:config tab #*See: #**http://kb.mozillazine.org/About:config #**http://kb.mozillazine.org/Location_Bar_search#Location_Bar_search_.28external_-_search_engine.29 #**http://kb.mozillazine.org/Keyword.url #**http://www.techrena.net/computers/address-bar-search-provider-firefox/ #If Yahoo is shown in your Search Bar and you want to remove it: #*https://support.mozilla.org/en-US/kb/Search%20bar '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.''' ------------------------- Not related to your question, but... You may need to update some plug-ins. Check your plug-ins and update as necessary: *Plug-in check --> http://www.mozilla.org/en-US/plugincheck/ *'''''Adobe Shockwave for Director Netscape plug-in''''': [https://support.mozilla.org/en-US/kb/Using%20the%20Shockwave%20plugin%20with%20Firefox#w_installing-shockwave Installing ('''''or Updating''''') the Shockwave plugin with Firefox] *Adobe PDF Plug-In For Firefox and Netscape: [https://support.mozilla.org/en-US/kb/Using%20the%20Adobe%20Reader%20plugin%20with%20Firefox#w_installing-and-updating-adobe-reader Installing/Updating Adobe Reader in Firefox] *'''''Shockwave Flash''''' (Adobe Flash or Flash): [https://support.mozilla.org/en-US/kb/Managing%20the%20Flash%20plugin#w_updating-flash Updating Flash in Firefox] *Next Generation Java Plug-in for Mozilla browsers: [https://support.mozilla.org/en-US/kb/Using%20the%20Java%20plugin%20with%20Firefox#w_installing-or-updating-java Installing or Updating Java in Firefox]
cor-el
  • Top 10 Contributor
  • Moderator
12902 solutions 118344 answers

Chosen Solution

Do you mean the search engine on the about:home page?

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

See also:

Do you mean the search engine on the about:home page? Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default. * Open the <b>about:config</b> page via the location bar * Type in the Filter bar: <b>mstone</b> * Right-click the <b>browser.startup.homepage_override.mstone</b> line and select: Reset * Close and restart Firefox If that didn't help then delete the delete the <b>chromeappsstore.sqlite</b> file in the Firefox Profile Folder and repeat the above. See also: * [[/questions/779082]] * http://forums.mozillazine.org/viewtopic.php?f=7&t=2158301&p=11018123#p11018123

Question owner

Safe-Browser

Thank you for the information but I haven't downloaded and installed anything new recently and I've already tried all of this.

Safe-Browser Thank you for the information but I haven't downloaded and installed anything new recently and I've already tried all of this.

Modified by Hydrassas

Question owner

Cor-el your solution fixed it. :)

Everyone, thank you for taking the time to try and help I really appreciate it! :D

Cor-el your solution fixed it. :) Everyone, thank you for taking the time to try and help I really appreciate it! :D
cor-el
  • Top 10 Contributor
  • Moderator
12902 solutions 118344 answers

You're welcome

You're welcome