Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java is not been friendly with Firefox 11 and above, I thought that the new 12 version would solve this issue but I was wrong, it does not work either

  • 1 reply
  • 58 have this problem
  • 85 views
  • Last reply by SafeBrowser

more options

Java is just not running on Firefox 11 or above, it keeps telling you that is not running and it needs to be installed, my operating system is Windows 7 x64bits. I don't know if this problem also exist on x86 bits OS. I really like Mozilla and for now I've been obligated to use IE9 for Java based webpages and I don't like it. Any help on this issue will be appreciated.

Modified by spiderm_91

All Replies (1)

more options
  • Firefox 12 (and all previous) is a 32-bit browser and requires the 32-bit version of Java. 32-bit browsers will run on 64-bit operating systems as you have experienced.
  • If you have both 32-bit and 64-bit browsers installed on your system, you will need to install both 32-bit and 64-bit Java.

See --> https://www.java.com/en/download/faq/java_win64bit.xml
See --> https://support.mozilla.org/en-US/kb/latest-firefox-issues#w_java-doesnt-work
See --> https://support.mozilla.org/en-US/kb/unblocking-java-plugin


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser