X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do you not leave me alone about updating firefox. like chill.

Posted

what is the importance of updating

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • 5.0.61118.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Citrix ICA Client Plugin (Win32)
  • Citrix offline plug-in Mozilla Plug-in (Win32)
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Enterprise(tm) LiveConnect-Enabled Plug-In
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

Midhun M 1 solutions 63 answers

fix several security flaws otherwise Browser will always be vulnerable to attack. bring out new features. fix bugs. Allow your applications to work more smoothly and efficiently. Avoid compatibility problems associated with older versions

Swarnava Sengupta 483 solutions 3135 answers

you can always change update option, instruction are here

Update Firefox to the latest version
whumwhum 0 solutions 2 answers

With the older version of Firefox....3.6.X.....when a security flaw has been detected, a new version is released and you can see the details with what has been fixed with the latest version of 3.6.X

Is it the same with current versions of Firefox.....such as, Firefox 11.0? We disable auto-updates here.

I also notice that there are no longer various language options for downloading...eg. Firefox in french, etc. I am assuming the language selection will be in the installation itself? Thanks.

Swarnava Sengupta 483 solutions 3135 answers

Helpful Reply

We are no more supporting Firefox 3.6. And 3.6.28 is the last version of Firefox 3.6 serious, it means no more further update, only chemspill support. You can download your preferred language version from here

whumwhum 0 solutions 2 answers

Thanks. Appreciate it. I will also download HTML Validator 0.9.5.1 as I understand this version of HTML Validator works with Firefox 11.0? I can se the grayed out wording that it works with version 5.0 to 11* There is an asterisk next to the number 11.....not sure what that indicates.