Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Plugin is needed to display problem

  • 3 replies
  • 152 have this problem
  • 13867 views
  • Last reply by cor-el

more options

HI I am experiencing a very weird problem within firefox web pages. every page i open on every website i visit i get in the bottom 1/3 of the display this error " A plugin isneeded to display this content" message.

the weird thing is that the whole page actually works but i have only 2/3 of the page displayed.

I have uninstalled and reinstalled fire fox twice and this problem still occurs. i haveno issue with IE explorer or Google Chrome.

If i cant find a resoloution to this i will have to sadley say goodbye to firefox i use it a lot in my work , but this problem is impacting badly

Surely i cant be th only one with this issue

any suggestions will be greatly appreciated

All Replies (3)

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Many Thank Cor-el. yoursolution helped me resolve it all, i ended up having to reset my tool bars etc safe mode made the problem dissapear .

Themes accelaration etc had no effect either.

very weird problem, my very first with Firefox

Kind Regards Kapasfreo

more options

You're welcome