X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

What version of Firefox can I use for a mac mini running OS X 10.4.10? Since firefox stuffed version 3.6.28 on my computer its been crashing every 2 minutes. I'm an old lady. Please provide specific directions on how to fix this problem.

Posted

What version of Firefox can I use for a mac mini running OS X 10.4.10? Since firefox stuffed version 3.6.28 on my computer its been ceasing to work and I have to force quit every 2 minutes. I'm an old lady. Please provide specific directions on how to fix this problem. my email is (Email removed by mod). Please nswer there. I don't know how to find the answer here.

Modified by Tyler Downer

Chosen solution

Unfortunately, Firefox 4 and later dropped support for mac 10.4 :( Firefox 3.6.28 is the latest version you can use on that Operating System.

Now, that said, have you tried to start Firefox in Safe Mode? That will test to see if your crashes are caused by an extension.

You can also try using the unofficial version of Firefox for Mac 10.4, tenfourfox. http://www.floodgap.com/software/tenfourfox/. Keep in mind this version is unofficial, and there is no support for it from Mozilla. But it might be worth a try.

Read this answer in context 1

Additional System Details

Crash ID

can't do this. have to force

Installed Plug-ins

don't know what a plug in is.

Application

  • User Agent:

More Information

Can't do this. have to force

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

Chosen Solution

Unfortunately, Firefox 4 and later dropped support for mac 10.4 :( Firefox 3.6.28 is the latest version you can use on that Operating System.

Now, that said, have you tried to start Firefox in Safe Mode? That will test to see if your crashes are caused by an extension.

You can also try using the unofficial version of Firefox for Mac 10.4, tenfourfox. http://www.floodgap.com/software/tenfourfox/. Keep in mind this version is unofficial, and there is no support for it from Mozilla. But it might be worth a try.

Question owner

Dear Tyler, Thank you for answering my question and being so specific. I tried, but in the end, I had to upgrade my operating system and now can run firefox11. Turned out for the best and didn't cost that much at Fix that Mac. They were helpful and courteous and did a good job which is just as well, because I am pretty helpless when it comes to making computers work - they are just tools to do other work for me. I know about as much about making a computer work as a TV - push the button...