X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Javascript buttons and links no longer work in Firefox after latest update

Posted

Whenever I try to use a javascript button or link, nothing happens, I just get a message in the bottom bar such as: "javascript:window.close();" telling me what the command is, but when I click on it, nothing happens. I cannot close windows in social security or in any other program using javascript. This has happened since the last upgrade to Firefox 11. I even tried completely uninstalling and reinstalling (using the Mozilla instructions to completely remove Firefox) a fresh Firefox eleven, to no avail. I made sure javascript was completely enabled in tools/options/content

Additional System Details

This happened

Every time Firefox opened

This started when...

I upgraded to Firefox eleven

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.2.72
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • 5.0.61118.0
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.1.0 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • npapicomadapter
  • Motive Plugin for Mozilla Browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Application Basics
Name
Firefox
Version
11.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Adblock Plus Pop-up Addon
0.3
true
adblockpopups@jessehakanen.net
RealPlayer Browser Record Plugin
15.0.2
true
{ABDE892B-13A8-4d1b-88E6-365A6E755758}
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage
my.yahoo.com
browser.startup.homepage_override.buildID
20120312181643
browser.startup.homepage_override.mstone
rv:11.0
dom.disable_window_flip
false
extensions.lastAppVersion
11.0
gfx.blacklist.direct2d
3
gfx.blacklist.layers.direct3d10
3
gfx.blacklist.layers.direct3d10-1
3
gfx.blacklist.layers.opengl
5
gfx.blacklist.webgl.opengl
5
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
33318
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) 82845G/GL/GE/PE/GV Graphics Controller
Vendor ID
8086
Device ID
2562
Adapter RAM
Unknown
Adapter Drivers
ialmrnt5
Driver Version
6.14.10.3943
Driver Date
11-2-2004
WebGL Renderer
false
GPU Accelerated Windows
0

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Question owner

Sorry, cor-el, nothing worked. Not restarting Firefox in Safe mode, or disabling everything, or troubleshooting, disabling hardware acceleration, etc. The links/buttons still work just fine in Opera browser, so it pretty near has to be a Firefox problem. I even checked to make sure all add-ons were up to date. The only add on I added after the clean reinstall of Firefox was AdBlock, anyhow. I even disabled it and restarted in Safe mode but No Joy.

So a supposedly clean reinstall has not solved the problem either. I followed the Mozilla knowledge base instructions on doing a completely clean reinstall, including manually deleting all leftover Mozilla Firefox data left over when the ADD/DELETE PROGRAMS uninstalled Firefox, and clicking in Firefox Uninstall to get rid of all user data. Nothing so far has worked. Anyone have any other ideas?

Modified by warpig

Question owner

Sorry, didn't work, see my reply (which I put in the wrong place for you to be notified - sorry).

rogue28219 0 solutions 1 answers

Helpful Reply

I have a similar problem like this. I dont know what the deal is but since some type of either add on upgrade or firefox upgrade i get notifications to install flash when i try to launch anything from google music. I did everything you can think of including uninstalling, reinstalling both the add on "No Script" Firefox itself, ran several diagnostic programs to ensure it wasnt any type of malware, reinstalled Adobe Flash 11, Verified Java version. I even tried to play music from google music in IE8 and that worked so its clearly Mozilla and its add ons. I disabled No Script and Google Music miraculously started working fine. This is pretty irritating considering I do everything in my power to ensure I dont get hit with any type of malware, virus, spyware, etc and No Script is definitely an Add on i like to use for that very reason since Firefox no longer supports the Norton Web Tracker add on. Any fix for this foolishness would be great, thanks!!

Question owner

As far as I know, I do not have "no script", at least it doesn't show in the add-ons or extension or plugins. Come to think of it, this problem popped up a month after my upgrade to a new Yahoo Messenger which, in spite of my un-checking the "install Yahoo toolbar" installed it anyway. Darn Yahoo and all their spawn. I had to uninstall the toolbar manually as it did not list on the "remove programs" section of the control panel in XP. But still, it should not have taken a month for this to appear, and especially only after I updated to Firefox eleven. It is still not fixed. For some reason the federal government loves to use java commands on their sites and this problem I am having severely limits Firefox's usefulness at government websites. So bad that I have to use Opera whenever I communicate via web with the feds for any reason.