X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I was recently able to attach files in gmail using Firefox, but now I get an unresponsive link, when I click "upload". It works fine on other browsers. I search the question database but perhaps I missed the fix. Any suggestions?

Posted

I am using windows 7 Home Premium, on an HP. I use and enjoy the Firefox browser. The only major extension that could cause clicking issues is possibly NoScript. But until recently I have had no problems with uploading attachments in Gmail through Firefox.

The issue: I start Gmail. Logging in is fine. When I compose a new message (still no problem) I can't upload any attachment via the attachment link. I click the attach link and it is unresponsive. I use internet explorer and I get no issues. I've noticed this issue only since yesterday. Please help.

Thanks R/S Kenneth

Chosen solution

I also had this problem since yesterday (march, 13). I tried cleaning cache and cookies, restarting the browser and the pc, but nothing happened. With IE and Chrome the attachment worked fine. I hoped that with the yesterday's 3.6.28 updade it would be fixed, but it didn't.

Then, I saw the reply to THIS SIMILAR PROBLEM which was telling to use the refresh button on FIREFOX (not Gmail's refresh). I tried, and the problem was gone.

So, if anybody has the same issue, try hitting the refresh button on firefox :)

Thank you, junkcat!

Read this answer in context 0

Additional System Details

Sites Affected

http://www.gmail.com/

Application

  • User Agent:

More Information

carolinadias 1 solutions 3 answers

Chosen Solution

I also had this problem since yesterday (march, 13). I tried cleaning cache and cookies, restarting the browser and the pc, but nothing happened. With IE and Chrome the attachment worked fine. I hoped that with the yesterday's 3.6.28 updade it would be fixed, but it didn't.

Then, I saw the reply to THIS SIMILAR PROBLEM which was telling to use the refresh button on FIREFOX (not Gmail's refresh). I tried, and the problem was gone.

So, if anybody has the same issue, try hitting the refresh button on firefox :)

Thank you, junkcat!

Question owner

Thank you carolinadias! But strangely today I have no problems attaching. I didn't even have to press refresh...