Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

dragging website names to bookmarks toolbar

  • 11 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

I used to be able to just click on a site address and drag it to the bookmarks toolbar so that all I had to do was click on the name and go right to that site. Right now I have several but the toolbar isn't even half full. Yet, somehow I am no longer able to do it. I click on the site address to highlight it, and drag it down to the toolbar to add it but when it gets to the toolbar it has one of those circles with a line going through it indicating that it isn't allowed. I don't know why I could do it in the past but can't now. Is there are setting that I might have chosen that changed the ability to do that? I have only adblock as an addon. I'm sure I had that when I added the other sites. Unless I am incorrectly remembering how I did that before but I am pretty sure I just clicked and dragged. Can anyone tell me what might have changed to not allow this anymore?

Chosen solution

Alright--nevermind. Got it to work. I didn't realize you had to add the website ICON (left of the website address) now in order to add it. I am absolutely SURE that I didn't use the icon before when I dragged the other sites. I've never even noticed the icon before. I always just clicked on the address to highlight it and dragged that. Perhaps firefox changed this in one of their updates. Thanks for the help though dad7732.

Read this answer in context 👍 0

All Replies (11)

more options

I noticed that if you drag the site address or favicon to the toolbar that if the drop point is a bit too far down you get the circle, I verified this several times. Try hovering over the toolbar more towards the center of the toolbar until the circle disappears.

more options

Thanks. I tried that but when I found a place where the circle disappeared, it just loaded the website page--didn't leave the site name on the toolbar. I have tried just about every millimeter of that toolbar and that circle is everywhere.

more options

Ok, just for curiosity sake, right-click on the open end of the bookmark bar and select "New Folder" and click Add. Now drag/drop the site to the "New Folder" and see if it stays there.

One other thing I MUST ask, so don't take offense .. you ARE dropping to the bookmark bar and NOT the TAB Bar, yes?

more options

It let me add a new folder but won't let me put a site into it. No offense taken, I'm not as literate as some on this stuff but yes, it's the bookmark bar. I went up and unchecked it just to be sure and it went away. I don't have a TAB bar that I can see.

more options

Also, I have tried the "restore default settings" and still am unable to add a new site

more options

Do HELP => Restart with addons disabled, click continue (don't check anything) and then try again to drag/drop.

more options

Ok tried that. When it restarted without addons it left my bookmark toolbar off as well. So I went up to options and checked the bookmark toolbar and it came back but still can't drag or drop a page. Oooh so frustrating.

more options

When you restart with addons disabled, there is a check box (radio button) for resetting toolbars. Try that. Also, can you drag/drop a site to a tab?

Modified by JayGarcia

more options

Chosen Solution

Alright--nevermind. Got it to work. I didn't realize you had to add the website ICON (left of the website address) now in order to add it. I am absolutely SURE that I didn't use the icon before when I dragged the other sites. I've never even noticed the icon before. I always just clicked on the address to highlight it and dragged that. Perhaps firefox changed this in one of their updates. Thanks for the help though dad7732.

Modified by hereshopin

more options

That's interesting because I can drag/drop by hiliting the address and not using the icon. Glad you got it fixed, I'll mark this as solved, thanks.

more options

It only works if you drag a text link with a protocol, so make sure that you have the protocol visible on the location bar.

You can set the pref browser.urlbar.trimURLs to false on the about:config page to see the http: protocol.