Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get Firefox to stop opening "Welcome to Firefox" EVERY time I open the browerser. It opens both "Wecome.." and my home page.

  • 9 replies
  • 25 have this problem
  • 1359 views
  • Last reply by dinger16

more options

Every time I updated Firefox to something higher than 3.xxx, each time I open the browser, "Welcome to Firefox" and my home page opens up. How do I get "Welcome to Firefox" to stop opening? Also...all the colors are missing on the menu bar. All the text is white............Bill

Chosen solution

Hi wbricki,

You should look at this article about that specific issue and the article Preferences not saved. These should give you all the information you need!

If that doesn't work:

  1. Type about:config in the address bar
  2. Click I'll be careful, I promise if prompted
  3. In the Filter input field type startup
  4. Double click on startup.homepage_override_url
  5. Delete the text string and click OK
  6. Close Firefox and reopen the window to verify that it has worked.

Hopefully this helps!

Read this answer in context 👍 4

All Replies (9)

more options

Chosen Solution

Hi wbricki,

You should look at this article about that specific issue and the article Preferences not saved. These should give you all the information you need!

If that doesn't work:

  1. Type about:config in the address bar
  2. Click I'll be careful, I promise if prompted
  3. In the Filter input field type startup
  4. Double click on startup.homepage_override_url
  5. Delete the text string and click OK
  6. Close Firefox and reopen the window to verify that it has worked.

Hopefully this helps!

more options

Thank you Matt_G. The "welcome" no longer opens! Any idea where the colors went for the text in the menu bar? The arrows use to be green and the home page icon was yellow. Now they are all white...............Bill

more options

Try a different Firefox theme (Tools > Add-ons > Appearance/Themes):

more options

Firefox 3 themes for Firefox 4 got the colors back on to the menu, but I lost the personas that I had chosen. Different personas had the same result. Seems like I can have one or the other, but not both. I am satisfied.

more options

Most themes do not work with a persona (i.e. have a skinnable:true setting), so you need to make a choice between a persona and a theme in such a case.

more options

Where is the filter input field in which to type start up.I have done about config, clicked I'll be careful but I get a whole list of items, but nothing that looks like filter input field thank you

Modified by dinger16

more options

The about:config should have a Filter bar at the top of that page.
You can also scroll down to the pref that you want to inspect or modify.

See:

Modified by cor-el

more options

I have search, rather than filter,[must be the difference between US and UK ?], but I have scrolled down to start up, deleted the text, clicked ok, but the welcome page is still there on start up. am I still doing something wrong, or is it something else. thank you

more options

On opening this morning it has gone, so whatever I did seems to have cracked it. thank you for your help