X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF does not play any more videos, the message is : "no video with supported format and mimetype found"; it worked perfectly two days ago, I have tried to reinstall everythingwith no effect and it is the same for nightlies. (Debian/Wheezy FF 9.0.1) Thanks

Posted

It is not a flash or other "standard" problem seen in forums on the web. It does not appear with epiphany or chromium.

When FF opens a page with a video (any type mp4, ogv, webm) I get a black or colored rectangle and the video is not played. It seems that the mimetype is considered as unknown...

Chosen solution

Problem solved ! Thanks to all contributors that helped progress. The solution seemed to be (?) :

# update-mime-database /usr/share/mime
# update-mime
update-desktop-database

then reboot

I cannot assure that this is precisely the answer but it is the last move I did before getting back the videos...I suppose that my root MIME database got corrupted in some way. I have also completely uninstalled and reinstalled all plugins.

Thanks again to the community

Read this answer in context 3

Additional System Details

This happened

Every time Firefox opened

This started when...

I cannot say when or why the problem started.

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Version 1.1.13 The Luggage, copyright 1996-2007 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120222 Firefox/13.0a1

More Information

When I use firebug I can see that the mimetype of the video is properly recognised but not played. I have installed/uninstalled all plugins (vlc, nonfree flash) with noeffect. The problem occurs also in html5 sites even on nightly start page, if htmltiming is present it is not possible to use it the video does not start and it is not possible to change chapters.
This morning after download of the nightly the video was played once but at the next start the message appeared and it was impossible to play the video again

Vivek 310 solutions 2084 answers

Helpful Reply

Hi,

You can try to check in Preferences > Applications, if the correct application is registered for the media type and if the application is still present on the system. You can also try deleting the mimeTypes.rdf in the Firefox Profile Folder. Firefox will reinitialize the DB and the file when it is started again.

Firefox Profile Files

Question owner

Checked again Preferences/Applications seems OK for example : vidéo MPEG-4 or vidéoWebM associated with VLC Multimedia Plug-in Checked "about:plugins" and installed packages seems OK VLCplugin is intalled all suffixes are available, Debian package is in the latest available version.

I have removed ~/.mozilla/.mozilla/firefox/utpss8l3.default/mimeTypes.rdf with no effect at all !

I have tried to run firefox (iceweasel) with sudo and it works perfectly ! That explains my morning observation, as the update of the nightly build is done by root. My problem seems to be linked with a configuration issue. Can you help me with a method to trace the origin of the bad behavior.

Vivek 310 solutions 2084 answers

Personally I'm not using Debian. These are general troubleshooting steps. You can try starting Firefox via the terminal and check the terminal for clues especially on problematic sites. You can also try the update-alternatives and xdg-mime commands and also check against the Firefox configuration. The Debian forums would also be very helpful: Debian User Forums and debianHELP

Question owner

I have created a new user, video does not work for Firefox but works for all other browsers. The problem is linked with firefox configuration of mimeTypes for ordinary users but does not appear for root user, I will check with Debian helpers but any hint onthe Firefox side will be very appreciated.

Vivek 310 solutions 2084 answers

If you are using SELinux, perhaps new policies could have been downloaded. You can check for any relevant warnings.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Do you see those MIME types listed on the about:plugins page?

Note that the VLC plugin can cause problems, so you can try to disable it and maybe use MPlayer and the Gecko Media player plugin instead


Question owner

The about:plugins page is correct with whatever plugin used totem or vlc, all the desired mimetypes are listed.

Thank-you for the pointer, I will follow the instructions when I'll be back on the machine. The point that puzzles me is that firefox works perfectly if started through sudo command and does not display the videos if started as normal user. For my last test I have removed all packages and all plugins (iceweasel, totem, vlc, flash) then installed aurora from downloaded .bz2 file. With the sudo command it plays properly the videos; without sudo it does not. As I have removed nouveau driver and installed propietary nvidia, I am wondering if I did something wrong, but does anybody know which library or other ressource firefox may use that chromium and epiphany don't ...?

Vivek 310 solutions 2084 answers

Please see this

Firefox on Linux

I think you should also try starting Firefox under sudo and also normally via the terminal and compare the output.

Chosen Solution

Problem solved ! Thanks to all contributors that helped progress. The solution seemed to be (?) :

# update-mime-database /usr/share/mime
# update-mime
update-desktop-database

then reboot

I cannot assure that this is precisely the answer but it is the last move I did before getting back the videos...I suppose that my root MIME database got corrupted in some way. I have also completely uninstalled and reinstalled all plugins.

Thanks again to the community

Modified by houbahop69

Vivek 310 solutions 2084 answers

Glad you did it :) Thanks very much for sharing the helpful info.

doctorcolin 0 solutions 1 answers

Helpful Reply

I had the same problem. YouTube wouldn't run either. The problem (at least in my case) was in the Real Player preferences. I found this solution. Try this:

1 Open Real Player 2 Click the Real Player "arrow" sign icon in the top left corner and you'll get a drop-down menu 3 Select "Download and Recording" from the bottom of the list 4 UN-CHECK the box that says "Enable Web Download & Recording for these installed browsers. (It will probably list other browsers on your system but not Firefox. 5 Click "OK" and then close Real Player. 6 Re-start Firefox (not the computer!) and your problem should be cleared.

I hope this works!

zacattack 0 solutions 1 answers

this solved my problem, thanks so much