Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook "like" button code not working in latest version

  • 3 replies
  • 17 have this problem
  • 2858 views
  • Last reply by jg808

more options

I have a site on which I have placed code for a Facebook "like" button, which fails to show up since I updated my version of Firefox to 10.02. It still seems to work on earlier versions of Firefox as well as Safari. I've included the code below, and would greatly appreciate any help anyone can provide.

All Replies (3)

more options

Hi DanRiech,

I'd try starting Firefox in Diagnose Firefox issues using Troubleshoot Mode. If you don't have the issue while all of your add-ons, extensions, and themes are disabled, you can try adding them back in one by one until you find the culprit. You should look at the Extensions and Themes troubleshooting guide and the Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems article as well.

Hopefully this helps!

more options

Does the code work if you paste this data URI in the location bar on an empty tab?


data:text/html;charset=utf-8,<div id="Layer8"><span class="footer">&nbsp;&nbsp;&nbsp;Like us on Facebook:</span><iframe src="http://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2FDownsizedLivingMagazine&amp;width=292&amp;colorscheme=light&amp;show_faces=false&amp;border_color&amp;stream=false&amp;header=true&amp;height=67" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:292px; height:67px;" allowTransparency="true"></iframe></div>

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Firefox > Preferences > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain. Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.


See also:

Modified by cor-el

more options

Not sure if this will show the button, but it fixed the functionality issue I was having in the latest FF on Mac.

Check your prefs for third-party cookies.

I tried to allow them until I close Firefox, but that did not seem to work (searches on the net indicate it has for some people).

I had to create an exception for fb, allowing for the session. That seems to work.

Modified by jg808