X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

"Bill Pay" feature on bank web site no longer works

Posted

My bank has a "bill pay" feature. I can log into the secure bank site pages without a problem, and get account information, transfer funds, etc. When I try to do the bill pay page, it simply does not load and reverts back to the previous page.

Things work as usual in Safari.

I think this began after I did the most recent update this morning (2/19). Nothing crashed; no error messages. I'm not aware of having changed any preference items.

I restarted the computer and Firefox. I am protected by a virus program.

Modified by kcupery

Additional System Details

Sites Affected

http://esl.org

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.60831.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Garmin Communicator Plug-in Version 2.9.3.0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

Noah_SUMO
  • Moderator
50 solutions 304 answers

Unfortunately, there is no way of getting around errors like that on banking sites. Could you imagine an error where you were on your bill pay page submitting a payment and after hitting submit, the page does something unexpected like reloading on its own or turning blank? Then you'd be left wondering did my payment go thru? Do I need to resubmit it? Or pray that the page reloading didn't cause the payment to be sent more than once resulting in you being billed twice.

Long story short, a lot of banks don't consider Firefox a browser that people like to use to access their site. Why that is exactly? I don't know. Probably resistance to change or that they would have to make too many modifications to make their banking site compatible with Firefox since we implement a lot of security changes.

Out of curiosity, which banking site do you have the problem with? Bank of America, Chase, Wells Fargo or Capital One? Or a local credit union bank site? If you can post the link to the site, I can try to file a report to get someone from Mozilla to reach out to the bank's website staff, tell them about the problem, and help them correct it if necessary. 9 times out of 10 though, the bank site probably won't be quick to fix this because "as long it works on Internet Explorer" that's good enough for them.

For now though, I suggest you keep using Safari to complete your banking. Unless this bothers you so much you want to try reverting to a earlier version of Firefox or try disabling your addons in case one of them might be the cause of the problem?

To disable all Firefox addons:
Click the Firefox button then Help > Restart with Add-ons Disabled

Modified by Noah_SUMO

Question owner

Thanks for the comments. I did what I probably should have done, which is check the "what's supported" on the bank's web site for bill-pay. Sure enough Forefox is not supported although I've used Firefox on this site for several years for this feature.

As you suggest, Explorer is "certified" and Safari is "supported" but only on Apple systems. I guess if they cover Safari they think they have us covered.

Bummer. So either they made some change over the weekend or the latest update to Firefox did something.

The bank involved is a local credit union who gets their web site from somebody, I am sure. Bank in question is http://www.esl.org.

Shnoodle 0 solutions 2 answers

Happens for me on both my Macs. My Mini runs OSX 10.6.8 and the Air runs OSX 10.7.3. It began after updating to Firefox v.12.0 in April 2012 on both computers, and the Safari update to v.5.1.5 also broke the same feature in Safari. It is something in the updates from both Mozilla and Apple. Was likely created while patching the recent Java holes. However, I have seen this problem before, a long time back after an update to Firefox. Had to switch to using Safari. Now they are both disallowing the page to redirect.

I can log in to my bank's website and do everything except load the bill pay page. I get a drop down message saying, "Firefox prevented this page from automatically redirecting to another page." I click the Allow button, but I only get the message box dropping down again saying the same thing. So, I click it again, but the page just reloads to the account listing page again and never goes to the bill pay page. I'm so angry and frustrated 'cause I cannot access the bill pay page with any of my browsers on either computer.

I tried the disable all extensions and addons. This didn't change anything. I checked the page Permissions and Security and all is fine.

My bank is a large credit union in Colorado (IBM users and many other) https://www.premiermembers.org/home/home I called them to tell them of the problem, but they were completely dismissive and clueless. They are like ostriches with their heads in the sand and tell me to use IE (aptly named Internet Exploder). What a joke, right?!?

I'm also having issues with the my.t-mobile log in page. Logging in is very sporadic and usually requires I remove all website data and reset every blasted thing!

PLEASE FIX THESE PROBLEMS

Noah_SUMO
  • Moderator
50 solutions 304 answers

You can try to return to the previous version of Firefox 11 for Mac:
http://www.mozilla.org/products/download.html?product=firefox-11.0&os=osx&lang=en-US

Let me know how that works for you.

I also predicted that customer support from banks would be less than helpful. See my reply at the very bottom of this post. They could at the very least note the issue and forward that to their IT department or webmaster of the site.

Banks don't like browsers that constantly change their code. They don't like testing if new releases of these browsers (Firefox & Google Chrome) are compatible with their site. Maybe they're cheap or too lazy to try. The majority of them only test compatibility with IE. But in the effort of fairness, Chrome & Firefox change their code too frequently to be sure they are compatible with most sites. But Safari does not, so they have no excuse there and at the very least your bill pay should work with that.

I found this "Contact Us" page:
http://www.premiermembers.org/home/cont

But the only choice that fits is "Other". And who knows if they'll read that.

Also for your T-mobile issue I have hunch about that. Could you start a new thread for that issue? It makes for a cleaner discussion and stops us from sending the owner of this thread email alerts.

Link to create new thread: https://support.mozilla.org/en-US/questions/new


My original reply to this banking issue I forgot to post months ago:
Thanks for the link. Yeah, I too have used Firefox for years over on Chase's website and fortunately I haven't hit any errors.

The other problem I remember is that Firefox developers can't diagnose bank website problems unless they have an account with the bank. Since they can't just register a free account for testing like at a forum or Ebay. So that really sucks. They have to wait for the bank to conduct their own testing (and that's assuming the bank even cares enough to do it) or hope one of the Firefox nerds that know how to do bug regression hunting comes along and also happens to have a bank account at that site.

Shnoodle 0 solutions 2 answers

I figured out why I could not access the Bill Pay page on either Firefox or Safari. It had to do with Accept third-party cookies in the Preferences Privacy section. That feature needs to marked as Always. I had marked as Never. My bank's info on browser settings is outdated though as to where to find some of the settings. I have them set now though so they work with both Firefox and Safari.