Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I open firefox, rather than 1 window opening I get 3 every time

  • 8 replies
  • 4 have this problem
  • 76 views
  • Last reply by Kulta

more options

How Can I get 3 tabs from opening every time I launch Firefox?

Chosen solution

I simply deleted Firefox and all addons then dl and installed them again

Thank you to all who tried to help

Read this answer in context 👍 0

All Replies (8)

more options

Hi Kulta,

Have you looked at the Home page with pipe character opens extra tabs when Firefox starts Knowledge Base article? That should resolve your issue for you.

Just out of curiosity, what are the pages that open? If it is the "Welcome to Firefox" page, you should look at this article about that specific issue and the article Preferences not saved. These should give you all the information you need!

If that doesn't work:

  1. Type about:config in the address bar
  2. Click I'll be careful, I promise if prompted
  3. In the Filter input field type startup
  4. Double click on startup.homepage_override_url
  5. Delete the text string and click OK
  6. Close Firefox and reopen the window to verify that it has worked.

Hopefully this helps!

more options

It is 3 tabs of my saved Homepage. I have told firefox what my homepage addy is and now instead of opening 1 it opens 3 every time-.

Well since the last update

Thank you for any help

I did your step by step and when I closed and re opened the browser again I got 3 tabs

Modified by Kulta

more options

Do you get three tabs in the same window or do you get three windows with each a tab?


It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the sessionstore.js [2] file and possible sessionstore-##.js [3] files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

See also:

more options

3 tabs in the same window

more options

Click on the Firefox button then click Options > Options.

Look at the screenshot below:

Do you have these | symbols in your homepage websites? If yes, delete each one and the websites that are next to it. Do not leave any of these | behind. Delete them all.

The bar symbol, | , adds a new tab. Even if there is no website listed after it.
For example: google.com||
This has 2 bars so 2 blank tabs will open and 1 tab will open with google.

more options

no I do not. Just the one addy and I get 3 tabs to the same home page in one window. No worries I will remove and re dl firefox see if that corrects it

more options

Did you try to delete or move the sessionstore files?

more options

Chosen Solution

I simply deleted Firefox and all addons then dl and installed them again

Thank you to all who tried to help