Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not remember passwords. I check the "Remember passwords for sites", however, whenever I restart Firefox, the " Remember Passwords for Sites" box is unchecked. How can I make the " Remember Passwords for Sites" box stay checked?

  • 3 replies
  • 4 have this problem
  • 75 views
  • Last reply by Husker007

more options

I am running on a Windows 7 desktop platform. I have looked for similar problems in a number of forums, but have not seen any postings that work in my situation.

Chosen solution

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


Read this answer in context 👍 1

All Replies (3)

more options

Hi,

Please see this. The KB article provides for different types of situations and solutions.

more options

Chosen Solution

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


more options

Thanks for posting suggestions. They prompted me to poke around in the add-ons. It appears that the XFINITY Constant Guard Protection Suite 1.0 add-on extension has caused the problem. For all who are using the free Norton Security Suite provided by Comcast XFINITY, please be aware that the Constant Guard Protection Suite may be resetting your browser (especially Firefox) settings. I turned it off in Firefox and the "Remember passwords for sites" has remained checked and Firefox continues to ask for and remember passwords.