X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Whenever I open a new tab, the page goes to http://isearch.babylon.com/?babsrc=NT_FFUP. How do I keep google my default page when opening new tabs?

Posted

Please assist on how I can make google.com my default page when opening new tabs.

Chosen solution

Hi, I'm sorry you're having this problem.

If it is a search engine in the search bar, see the Search bar - Easily choose your favorite search engine article for details of how to remove a search engine.

If you have the Babylon Toolbar, follow the procedure in the Disable or remove Add-ons article, in particular the section on uninstalling extensions and themes

After you get rid of Babylon, you should be able to set google as your home page again.

Thanks, Michelle

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Pando Web Plugin
  • GEPlugin
  • Google Update
  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

More Information

mluna
  • Administrator
  • Moderator
66 solutions 462 answers

Chosen Solution

Hi, I'm sorry you're having this problem.

If it is a search engine in the search bar, see the Search bar - Easily choose your favorite search engine article for details of how to remove a search engine.

If you have the Babylon Toolbar, follow the procedure in the Disable or remove Add-ons article, in particular the section on uninstalling extensions and themes

After you get rid of Babylon, you should be able to set google as your home page again.

Thanks, Michelle

Question owner

I did not know a lot of people has this same problem with Babylon. What is up with them? Yicks!

Thank you Michelle.

tcw87544 0 solutions 1 answers

Helpful Reply

In the top bar type about:config Then enter in filter keyword.URL Right click on modify and click modify Delete http://isearch.babylon.com/?babsrc=NT_FFUP and put in http://www.google.co.in/search?btnG=Google+Search&q= to change it to google.

Shahnawaz 0 solutions 1 answers

Helpful Reply

1. Open a new Firefox window and type about:config

2. Now, in Search bar type Babylon and now in all the listed options right click and click Reset.

3. Restart Mozilla and all Babylon gone!

milesBivanni 0 solutions 1 answers

I did all the things that were suggested here (and other posts), but to no avail.

Here's the list of all past suggestions I tried: (1) uninstalling babylon ... didn't work! (2) disabling/deleting add ons ... didn't show up on list!! (3) deleted it as a choice on search engine text box ... didn't eliminate the problem!!! (4) did the about:config trick ... didn't work!!!! (5) tried modify the "host" file ... didn't work!!!!!

... very, very frustrating indeed !!!!

But then tried this ... took about 5-7 minutes.

(1) Backed up bookmarks on Firefox (Bookmarks -> Show All Bookmarks -> Import & Backup -> Backup; save as file to desktop) (2) Made sure I had an EARLIER version of Firefox in my download file (I was using v.12, so I made sure I had v.11) (3) Uninstalled current Firefox version. (4) Reinstall past version (for me v.11) of Firefox. (5) Restore all old bookmarks to this new install of Firefox ( (Bookmarks -> Show All Bookmarks -> Import & Backup -> Restore -> Choose File; enter file from desktop).

... and ... VOILA! It works!!!

Hope this helps...