X
Tap here to go to the mobile version of the site.

Support Forum

When I start Firefox, I get msg that it is in "offline mode" and need to "try again" to get online. Started after latest update 10.0.1

Posted

When I click onto the Mozilla Firefox icon and open the browser up, it doesn't automatically connect to the online server. Instead, a message appears that it is in offline mode. If I want to go online, I am instructed to click a "Retry" button. This then initiates the online mode. It doesn't happen all the time but most often first thing in the morning and/or if Firefox has not been opened for a few hours. Is there something I need to change in the Firefox Preferences under Network/Connection/ Settings?

When I click onto the Mozilla Firefox icon and open the browser up, it doesn't automatically connect to the online server. Instead, a message appears that it is in offline mode. If I want to go online, I am instructed to click a "Retry" button. This then initiates the online mode. It doesn't happen all the time but most often first thing in the morning and/or if Firefox has not been opened for a few hours. Is there something I need to change in the Firefox Preferences under Network/Connection/ Settings?

Additional System Details

This happened

Every time Firefox opened

This started when...

This started happening after the latest update, about a week ago.

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.60531.0
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

More Information

Moses
  • Moderator
459 solutions 3607 answers

Hi there!

Type in this command in the Terminal:

firefox.exe -ProfileManager

(To open the Terminal go to the Spotlight search on the top right corner of your desktop, click it, and type Terminal.

Look for a setting that says Work Offline is unchecked. If it is checked, uncheck it then continue.

Also if that doesn't work, you can try changing it from Firefox itself. Go to about:config, search for browser.offline, double-click the value for it and change it to False.

Hi there! Type in this command in the Terminal: '''firefox.exe -ProfileManager''' (To open the Terminal go to the Spotlight search on the top right corner of your desktop, click it, and type '''Terminal'''. Look for a setting that says '''Work Offline''' is unchecked. If it is checked, uncheck it then continue. Also if that doesn't work, you can try changing it from Firefox itself. Go to '''about:config''', search for '''browser.offline''', double-click the value for it and change it to ''False''.

Modified by Moses

Question owner

I tried the first solution but the screen that came up resembled old DOS screens and response after typing in firefox.exe -ProfileManager was "Command not found"

I tried your second solution and changed the browser:offline to False. No problem when I rebooted Firefox immediately after. I will see how it works tomorrow morning. As I mentioned for some reason it happens most often when Firefox has not been opened for several hours.

Thanks for the suggestion and I will let you know tomorrow.

MJC

I tried the first solution but the screen that came up resembled old DOS screens and response after typing in firefox.exe -ProfileManager was "Command not found" I tried your second solution and changed the browser:offline to False. No problem when I rebooted Firefox immediately after. I will see how it works tomorrow morning. As I mentioned for some reason it happens most often when Firefox has not been opened for several hours. Thanks for the suggestion and I will let you know tomorrow. MJC
Moses
  • Moderator
459 solutions 3607 answers

mjc06:

Alright. If you have any trouble just post back here.

mjc06: Alright. If you have any trouble just post back here.

Modified by Moses

cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

On a Mac you need to use another command to start the profile manager, probably firefox-bin -P (firefox.exe is for Windows).

Did you check the setting in File > Work Offline ?

On a Mac you need to use another command to start the profile manager, probably firefox-bin -P (firefox.exe is for Windows). Did you check the setting in File > Work Offline ?
imanoot 0 solutions 6 answers

I have had same problem since updating to 10.0.1. Tried all the recommended solutions and none of them work. In the prefs file it says that work offline is set to false. Starting to get annoying now so tend to use safari instead!!!

I have had same problem since updating to 10.0.1. Tried all the recommended solutions and none of them work. In the prefs file it says that work offline is set to false. Starting to get annoying now so tend to use safari instead!!!

Question owner

OK, so this is the day after I applied MJB's second solution, i.e. open Firefox and typed in about:config, then went to browser:offline and changed it to False. Things were fine opening and closing Firefox yesterday.

Unfortunately, today, when I opened Firefox for the 1st time, I got the same msg. It first opens and says it is offline and I have to click "Retry" for it to work online. I rechecked settings on about:config and browser:offline is still "False"...so not sure what to do at this time.

In response to Cor-el, yes. The first thing I did was to make sure "Work Offline" was NOT checked in Firefox. Besides, I can get onto the server. The problem is that when I first open Firefox in the morning, it can't seem to make the online connection on the first try.

If someone could tell me the terminal command to access Profile Manager for a Mac, I could try that suggestion. (Firefox.exe - ProfileManager doesn't work)

Thanks all.

OK, so this is the day after I applied MJB's second solution, i.e. open Firefox and typed in about:config, then went to browser:offline and changed it to ''False''. Things were fine opening and closing Firefox yesterday. Unfortunately, today, when I opened Firefox for the 1st time, I got the same msg. It first opens and says it is offline and I have to click "Retry" for it to work online. I rechecked settings on about:config and browser:offline is still "False"...so not sure what to do at this time. In response to Cor-el, yes. The first thing I did was to make sure "Work Offline" was NOT checked in Firefox. Besides, I can get onto the server. The problem is that when I first open Firefox in the morning, it can't seem to make the online connection on the first try. If someone could tell me the terminal command to access Profile Manager for a Mac, I could try that suggestion. (Firefox.exe - ProfileManager doesn't work) Thanks all.
imanoot 0 solutions 6 answers

Something that I have tried is to rename my prefs.js file to prefs.js.OLD and then re-open firefox. This should create a new prefs database. Just need to wait and see now whether the problem occurs in the morning. Downside to this is a) it may not work and b) you have to recreate all your personal preferences. If this does not work then the next step will be a total removal and re-install.

Something that I have tried is to rename my prefs.js file to prefs.js.OLD and then re-open firefox. This should create a new prefs database. Just need to wait and see now whether the problem occurs in the morning. Downside to this is a) it may not work and b) you have to recreate all your personal preferences. If this does not work then the next step will be a total removal and re-install.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Try to set the Boolean pref network.manage-offline-status to false on the about:config page.

Try to set the Boolean pref <b>network.manage-offline-status</b> to <i>false</i> on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config
imanoot 0 solutions 6 answers

UPDATE.....the new pref.js file so far is working. Not had the problem at all since applying last night.....fingers crossed...will keep you posted

UPDATE.....the new pref.js file so far is working. Not had the problem at all since applying last night.....fingers crossed...will keep you posted
Moloko 0 solutions 5 answers

I have this problem too. Firefox opens, but when I try to do anything, I get the offline msg and told to click "try again." I do, and then things are fine, but I don't like having to take this extra step.

Looked under File on the menu; Work offline is not checked.

Went to the about:config page; set value of network.manage-offline-status to false.

Set browser.offline value to false.

Set browser.offline-apps.notify to false.

Opened Terminal and typed /Applications/Firefox.app/Contents/MacOS/firefox-bin -p in the window that opened.

Still get the same result.

I have this problem too. Firefox opens, but when I try to do anything, I get the offline msg and told to click "try again." I do, and then things are fine, but I don't like having to take this extra step. Looked under File on the menu; Work offline is not checked. Went to the about:config page; set value of network.manage-offline-status to false. Set browser.offline value to false. Set browser.offline-apps.notify to false. Opened Terminal and typed /Applications/Firefox.app/Contents/MacOS/firefox-bin -p in the window that opened. Still get the same result.
sreinhard1 0 solutions 2 answers

I have been having this problem since yesterday. I vaguely remember doing something and accidentally clicked a box that immediately disappeared. I mean I can get it to work after clicking try again but it's annoying. Always after it's been off a few hours. I am terrified of hitting the wrong thing and I am NOT a programmer. The help answers are useless and I don't want to make a mess. I need a fast and simple solution. Thanks.

I have been having this problem since yesterday. I vaguely remember doing something and accidentally clicked a box that immediately disappeared. I mean I can get it to work after clicking try again but it's annoying. Always after it's been off a few hours. I am terrified of hitting the wrong thing and I am NOT a programmer. The help answers are useless and I don't want to make a mess. I need a fast and simple solution. Thanks.
sreinhard1 0 solutions 2 answers

I just noticed that when I reboot, FIREFOX is set to automatically open and that's when I get the try again problem. How can I stop it from opening automatically?

I just noticed that when I reboot, FIREFOX is set to automatically open and that's when I get the try again problem. How can I stop it from opening automatically?
Moloko 0 solutions 5 answers

I had a similar issue re the automatic opening and deleted Firefox and reinstalled. That fixed it.

But I still get the try again msg intermittently.

I had a similar issue re the automatic opening and deleted Firefox and reinstalled. That fixed it. But I still get the try again msg intermittently.
momofjkg 0 solutions 2 answers

Helpful Reply

None of these "fixes" seem apply to Mac OSX10.6.8 . Since I installed the latest update for Firefox I, too, am getting this offline mode and retry message every time I open the browser.

I am not a programmer, so will appreciate a fix I can understand and safely execute to make this terribly annoying message go away.

Work Offline is NOT checked but does appear under the file menu.

None of these "fixes" seem apply to Mac OSX10.6.8 . Since I installed the latest update for Firefox I, too, am getting this offline mode and retry message every time I open the browser. I am not a programmer, so will appreciate a fix I can understand and safely execute to make this terribly annoying message go away. Work Offline is NOT checked but does appear under the file menu.
032212 0 solutions 3 answers

Helpful Reply

I have to agree with 'momofjkg', none of the fixes work on OS X 10.6.8. I have updated to the very latest Firefox 11.0 and it's still the same crap -- defaults to Work Offline regardless the settings. One would think that in this day and age, ability to properly program application's default settings is a given. Maybe Firefox programmers came from Microsoft, I don't know... Well, I trashed it and now I use Safari, and believe me, this fix WORKS!

I have to agree with 'momofjkg', none of the fixes work on OS X 10.6.8. I have updated to the very latest Firefox 11.0 and it's still the same crap -- defaults to Work Offline regardless the settings. One would think that in this day and age, ability to properly program application's default settings is a given. Maybe Firefox programmers came from Microsoft, I don't know... Well, I trashed it and now I use Safari, and believe me, this fix WORKS!