X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does F'fox not allow Downloading latest Version saying I need OS5 or 6 & say my Op.System doesn't support latest when I DO have OSX 10.5.8 & plenty of RAM/HD space?!

Posted

As above: When I launch Ff I get link to download latest Version (?4) I get page saying: -Unfortunately the latest version of Firefox isn't compatible with your computer's operating system. When I click "learn more" I get: -Mac Operating Systems

   * Mac OS X 10.5
   * Mac OS X 10.6

Recommended Hardware

   * Macintosh computer with an Intel x86 processor
   * 512 MB of RAM
   * 200 MB hard drive space

- I have OSX10.5.8, I have 1.8GHz PowerPC G5 Processor, 1GB DDR SD RAM... What's wrong please - HELP?!?

Chosen solution

You have a PPC processor, not an Intel x86 processor.

Firefox 3.6.x is the last available from Mozilla for PPC Macs.
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in the Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported
http://code.google.com/p/tenfourfox/wiki/AAATheFAQ

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Garmin Communicator Plug-in Version 2.9.1.0
  • Gecko default plugin
  • RealPlayer Plugin
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.26) Gecko/20120128 Firefox/3.6.26

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Chosen Solution

You have a PPC processor, not an Intel x86 processor.

Firefox 3.6.x is the last available from Mozilla for PPC Macs.
http://www.mozilla.com/en-US/firefox/all-older.html

For older Macs that aren't supported in the Firefox 4+ versions, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/
http://tenfourfox.blogspot.com/
https://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported
http://code.google.com/p/tenfourfox/wiki/AAATheFAQ